Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64704 - community/nextcloud doesn't work on current extra/php package(s)

Attached to Project: Arch Linux
Opened by Steven Noonan (neunon) - Monday, 02 December 2019, 12:21 GMT
Last edited by Antonio Rojas (arojas) - Monday, 02 December 2019, 12:26 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: community/nextcloud-17.0.1-1 doesn't work on current extra/php-7.4.0-2


Additional info:

$ pacman -Q | grep -e nextcloud -e php
nextcloud 17.0.1-1
php 7.4.0-2
php-fpm 7.4.0-2
php-gd 7.4.0-2
php-igbinary 3.0.1-3
php-imagick 3.4.4-5
php-intl 7.4.0-2
php-pgsql 7.4.0-2
php-redis 5.1.1-3
php-sqlite 7.4.0-2

Upstream pull request for PHP 7.4 support, merged and due to be released as part of Nextcloud 18 in mid-January sometime: https://github.com/nextcloud/server/pull/18064#


Steps to reproduce:

Install Nextcloud, attempt to run with PHP 7.4.x. All requests will currently result in this page:

---
This version of Nextcloud is not compatible with > PHP 7.3.
You are currently running 7.4.0.
---
This task depends upon

Closed by  Antonio Rojas (arojas)
Monday, 02 December 2019, 12:26 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#64689 
Comment by Steven Noonan (neunon) - Monday, 02 December 2019, 12:26 GMT
Temporary workaround for my case is to just install old php* packages from https://archive.archlinux.org/packages and ignore php packages on pacman upgrades, but this is obviously not ideal.

Loading...