Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64691 - upgrading to mercurial 5.2 now no longer runs: abandon : No module named peer !

Attached to Project: Arch Linux
Opened by Richard PALO (risto3) - Saturday, 30 November 2019, 07:16 GMT
Last edited by Antonio Rojas (arojas) - Saturday, 30 November 2019, 08:46 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

upgrade this morning included
[2019-11-30T07:11:21+0100] [ALPM] upgraded mercurial (5.1.2-1 -> 5.2-1)

Now I can no longer run mercurial, getting:
$ hg summary
abandon : No module named peer !

Additional info:
* package version(s) 5.2
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:
(with traceback)
$ cd /tmp
$ hg init --traceback foo
Traceback (most recent call last):
File "/usr/lib/python2.7/site-packages/mercurial/scmutil.py", line 177, in callcatch
return func()
File "/usr/lib/python2.7/site-packages/mercurial/dispatch.py", line 414, in _runcatchfunc
return _dispatch(req)
File "/usr/lib/python2.7/site-packages/mercurial/dispatch.py", line 1174, in _dispatch
lui, repo, cmd, fullargs, ui, options, d, cmdpats, cmdoptions
File "/usr/lib/python2.7/site-packages/mercurial/dispatch.py", line 862, in runcommand
ret = _runcommand(ui, options, cmd, d)
File "/usr/lib/python2.7/site-packages/mercurial/dispatch.py", line 1185, in _runcommand
return cmdfunc()
File "/usr/lib/python2.7/site-packages/mercurial/dispatch.py", line 1171, in <lambda>
d = lambda: util.checksignature(func)(ui, *args, **strcmdopt)
File "/usr/lib/python2.7/site-packages/mercurial/util.py", line 1843, in check
return func(*args, **kwargs)
File "/usr/lib/python2.7/site-packages/mercurial/commands.py", line 4393, in init
hg.peer(ui, opts, ui.expandpath(dest), create=True)
File "/usr/lib/python2.7/site-packages/hggit/__init__.py", line 353, in peer
newpeer = orig(uiorrepo, *args, **opts)
File "/usr/lib/python2.7/site-packages/mercurial/hg.py", line 234, in peer
rui, path, create, intents=intents, createopts=createopts
File "/usr/lib/python2.7/site-packages/mercurial/hg.py", line 194, in _peerorrepo
hook(ui, obj)
File "/usr/lib/python2.7/site-packages/hggit/__init__.py", line 232, in reposetup
if not isinstance(repo, gitrepo.gitrepo):
File "/usr/lib/python2.7/site-packages/hgdemandimport/demandimportpy2.py", line 157, in __getattr__
self._load()
File "/usr/lib/python2.7/site-packages/hgdemandimport/demandimportpy2.py", line 97, in _load
_origimport, head, globals, locals, None, level
File "/usr/lib/python2.7/site-packages/hgdemandimport/demandimportpy2.py", line 44, in _hgextimport
return importfunc(name, globals, *args, **kwargs)
File "/usr/lib/python2.7/site-packages/hggit/gitrepo.py", line 12, in <module>
from mercurial.peer import peerrepository
File "/usr/lib/python2.7/site-packages/hgdemandimport/demandimportpy2.py", line 284, in _demandimport
mod = _hgextimport(_origimport, name, globals, locals)
File "/usr/lib/python2.7/site-packages/hgdemandimport/demandimportpy2.py", line 44, in _hgextimport
return importfunc(name, globals, *args, **kwargs)
ImportError: No module named peer
abandon : No module named peer !
This task depends upon

Closed by  Antonio Rojas (arojas)
Saturday, 30 November 2019, 08:46 GMT
Reason for closing:  Not a bug
Additional comments about closing:  hg-git is not supported
Comment by Richard PALO (risto3) - Saturday, 30 November 2019, 07:20 GMT
BTW running:
Linux sarchx64 5.3.13-arch1-1 #1 SMP PREEMPT Sun, 24 Nov 2019 10:15:50 +0000 x86_64 GNU/Linux

Loading...