Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64677 - [ardour] Clock font too small

Attached to Project: Community Packages
Opened by Greg Mitchell (m3rlyn) - Thursday, 28 November 2019, 18:33 GMT
Last edited by David Runge (dvzrv) - Monday, 25 May 2020, 21:35 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To David Runge (dvzrv)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description: Using Preferences > Appearance > GUI and font scaling to return the GUI to what it was like in 5.12-11 makes the clock font too small.


Additional info:
* package versions : 5.12-12 and 5.12-13

Steps to reproduce:

Upgrade to 5.12-13 from 5.12-11
Launch Ardour
The 'Session Setup' dialogue appears with a font that is too big.
Open a session and return the font to a sensible size with GUI scaling
Small fonts are now microscopic.
Delete ~/.config/ardour5 relaunch Ardour and go back through the setup process
Fonts are too big
Return them to a good size with GUI scaling
All good except the clock, which is too small

This task depends upon

Closed by  David Runge (dvzrv)
Monday, 25 May 2020, 21:35 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed with ardour 6.0-1
Comment by Daniel Appelt (daniel.appelt) - Sunday, 08 December 2019, 13:55 GMT
I see the same phenomenon. I had to scale down the GUI to 80% in order to bring most elements back to their original size. The clock font is way too small now.
Comment by Miroslav Kováč (mj15003) - Friday, 10 January 2020, 13:09 GMT
I experienced the same. I downgraded from version 5.12-13 to 5.12-11 and diff-ed /etc/ardour5 between both versions. There were many differences. For example, in file 'clearlooks.rc' the same style has been defined as 'font_name = "ArdourMono 8"' in version 11 and as 'font_name = " "' in version 13. I guess this might give a hint for somebody (maintainer?) to be able to fix it.
Comment by David Runge (dvzrv) - Friday, 17 January 2020, 01:38 GMT
Hm, one of the major changes were the fix for the gtk theme issues: https://bugs.archlinux.org/task/54389

Are you using specific GTK themes?
Comment by Greg Mitchell (m3rlyn) - Saturday, 18 January 2020, 02:57 GMT
I use lxappearance to set my theme and it's Material-Black-Mango. I just tried Adwaita-dark and the clock font is still too small. At the time I, like Miroslav Kováč, noticed a file that had had a list of fonts now had empty double quotes.
Comment by David Runge (dvzrv) - Saturday, 18 January 2020, 12:51 GMT
I see. It's fairly possible that the thousands and thousands of lines of waf spaghetti code changed their behavior between python2 and python3.

As reference, this is the branch [1] I have been working on to port all the waf stuff to python3.
There's another one for the current master branch [2] (as *a lot* has changed over the years) and here's the pull request[3].

I'm fairly sure, that the culprit it somewhere in these lines [4] for clearlooks.rc, for which the substition dictionary gets assembled here [5].

I don't have a lot of time for debugging this, so any help is highly appreciated (also in regards to the opened pull-request, as it ensures, that ardour will still be buildable in the future on normal distributions).

[1] https://github.com/dvzrv/ardour/tree/feature/python3_waf
[2] https://github.com/dvzrv/ardour/tree/feature/current_waf
[3] https://github.com/Ardour/ardour/pull/459
[4] https://github.com/dvzrv/ardour/blob/feature/python3_waf/gtk2_ardour/wscript#L795-L799
[5] https://github.com/dvzrv/ardour/blob/feature/python3_waf/gtk2_ardour/wscript#L722-L781
Comment by Greg Mitchell (m3rlyn) - Saturday, 18 January 2020, 20:52 GMT
Thanks. I appreciate all you do for music and audio on Linux.

What you posted looks beyond my present abilities, but I will look at it and see if I can do anything.
Comment by David Runge (dvzrv) - Monday, 25 May 2020, 15:27 GMT
@m3rlyn: Please check whether this is still an issue with ardour 6.0
Comment by Greg Mitchell (m3rlyn) - Monday, 25 May 2020, 19:47 GMT
The issue is resolved in ardour 6.0. The clock font is a good size and everything looks good.
Comment by David Runge (dvzrv) - Monday, 25 May 2020, 21:35 GMT
@m3rlyn: Good stuff. Thanks for the confirmation!

Loading...