Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64658 - [ardour] Ardour cannot find its built-in plugins

Attached to Project: Community Packages
Opened by James Crompton (DonJaime) - Tuesday, 26 November 2019, 18:03 GMT
Last edited by David Runge (dvzrv) - Thursday, 28 November 2019, 08:31 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To David Runge (dvzrv)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Ardour comes with a small set of built-in LV2 plugins (in /usr/lib/ardour5/LV2/).

Version 5.12-12 can't find them.

When opening a session that uses these plugins, ardour notes that it can't find them, and replaces them with a non-functional stub.

Version 5.12-11 did not have this problem.
This task depends upon

Closed by  David Runge (dvzrv)
Thursday, 28 November 2019, 08:31 GMT
Reason for closing:  Fixed
Additional comments about closing:  Regression fixed (and upstreamed) in 5.12-13
Comment by David Runge (dvzrv) - Wednesday, 27 November 2019, 16:19 GMT
@DonJaime: Thanks for the report! I can confirm this.

I think it's likely due to the waf fix I did (python2 -> python3).

It seems the manifest.ttl now points `lv2:binary` to a file, that doesn't have a `.so` suffix.
I'll try to fix this in the build system asap.

Loading...