Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64645 - [pacman] missing gawk dependency

Attached to Project: Arch Linux
Opened by Michel (xantares) - Monday, 25 November 2019, 19:17 GMT
Last edited by Eli Schwartz (eschwartz) - Monday, 25 November 2019, 19:19 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
The pacman package is missing the awk dependency (gawk package):
/usr/sbin/pacman-key: line 214: awk: command not found

Steps to reproduce:
use the following docker image, you will see the error pop out:

FROM archlinux/base
RUN pacman-key --init
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Monday, 25 November 2019, 19:19 GMT
Reason for closing:  Not a bug
Additional comments about closing:  The container should have 'base' installed.

Loading...