Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64627 - [teamspeak3] Client crashes when you use the input device.

Attached to Project: Community Packages
Opened by Javier Fernández (WyRe) - Sunday, 24 November 2019, 00:02 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Wednesday, 25 March 2020, 01:05 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sven-Hendrik Haase (Svenstaro)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
The teamspeak3 client crashes when you are about to use the audio input. Even when you are disconnected, if you do a capture test apparently all is going well, but when you talk to the microphone the client crashes.

The 3.2.5 version is working as expected, but after 3.3.0 update all have the same bug and the client is crashing when you are about to use the microphone.

I'm attaching the terminal output after the crash.

Steps to reproduce:
1. Open the client
2. Go Tools > Capture > Being test
3. Use the microphone
4. The client should crash.
This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Wednesday, 25 March 2020, 01:05 GMT
Reason for closing:  No response
Comment by Javier Fernández (WyRe) - Tuesday, 03 December 2019, 14:56 GMT
I've been talking about the issue in https://forum.teamspeak.com/threads/141135-Discussion-TeamSpeak-Client-3-3-x?p=477445#post477445

The issue apparently seems to be related with 3.3.x versions, just as I suspected. I hope a 3.5.0 update soon.

Thank you anyway.
Comment by Javier Fernández (WyRe) - Wednesday, 04 December 2019, 15:55 GMT
A temporary workaround if you are experiencing this issue, until 3.5.0 version be released, is download the 3.3.2 version from

https://www.teamspeak.com/en/downloads/

(which is a installer called 'TeamSpeak3-Client-linux_amd64-3.3.2.run') install locally that version using the .run binary and then go to

Tools > Options > Application > Update Channel

Choose the Beta channel, then in

Help > Check for update

Should download the update and finally you should get the 3.5.0 version working.

I'll request the closure when the new 3.5.0 version be released an packaged, meanwhile ... I consider this as an upstream bug.
Comment by Sven-Hendrik Haase (Svenstaro) - Sunday, 23 February 2020, 04:13 GMT
Welp, nothing to do here. I'll leave the bug open to avoid duplicates but apart from that we'll just have to wait.
Comment by Pablo (pablo1) - Saturday, 07 March 2020, 08:11 GMT
Any updates? I have been not updating the client due to this issue for a while, but now I have to if I want to connect to any server I use. Everything runs fine, until audio is send or received. If I disable the Audio interface in the options I can run teamspeak without problems. With it enabled, it will crash as soon as someone says anything in the channel I'm in.
Comment by Sven-Hendrik Haase (Svenstaro) - Thursday, 19 March 2020, 17:57 GMT
Can you recheck this? I can't reproduce this with 3.5.0-1.

Loading...