Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64593 - [python-html2text] Does not accept text from stdin

Attached to Project: Community Packages
Opened by FichteFoll (FichteFoll) - Wednesday, 20 November 2019, 16:59 GMT
Last edited by Eli Schwartz (eschwartz) - Friday, 25 September 2020, 06:16 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Jaroslav Lichtblau (Dragonlord)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

Similar to https://bugs.archlinux.org/task/42970, when piping text into html2text, an exception is thrown.
A fix is already available in version 2019.9.26.

Additional info:
* package version: 2019.8.11
* upstream report: https://github.com/Alir3z4/html2text/issues/287

Steps to reproduce:

~ $ echo "text" | html2text
Traceback (most recent call last):
File "/usr/bin/html2text", line 11, in <module>
load_entry_point('html2text==2019.8.11', 'console_scripts', 'html2text')()
File "/usr/lib/python3.8/site-packages/html2text/cli.py", line 262, in main
data = data.decode(args.encoding, args.decode_errors)
AttributeError: 'str' object has no attribute 'decode'
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Friday, 25 September 2020, 06:16 GMT
Reason for closing:  Fixed
Additional comments about closing:  python-html2text 2020.1.16-1
Comment by FichteFoll (FichteFoll) - Thursday, 09 January 2020, 03:43 GMT
Any updates on this?
Comment by Eli Schwartz (eschwartz) - Wednesday, 12 February 2020, 15:14 GMT
The new version of python-html2text drops python2 support which is a bit awkward since we have a package that depends on it.
Comment by ilf (ilf) - Thursday, 26 March 2020, 09:16 GMT
I am also experiencing this bug and it's rather annoying, because it makes the entire tool useless for my use-case.

I would love to get a package with the current version (by now 2020.1.16).

Surely, we could rather break one ancient python-2 dependency than the current version of the tool itself?

Thanks!

(Also, maybe the "upstream URL" should be https://alir3z4.github.io/html2text/)
Comment by Eli Schwartz (eschwartz) - Friday, 25 September 2020, 06:14 GMT
Sorry, I kind of sort of intended to maybe release the python3 and python2 versions separately. Then I forgot.

But now it's a moot point, since the remaining python2 use is gone (calibre got updated to use python3), so we're just going to upgrade it now, while I drop a bunch of python2 legacy packages.

Loading...