Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64586 - [avahi][nss-mdns] dependencies are reversed

Attached to Project: Arch Linux
Opened by nl6720 (nl6720) - Wednesday, 20 November 2019, 10:06 GMT
Last edited by Antonio Rojas (arojas) - Tuesday, 10 December 2019, 17:30 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Antonio Rojas (arojas)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Avahi in no way uses nss-mdns, but nss-mdns requires Avahi to actually work. nss-mdns used to support mDNS resolution without Avahi, but that was removed some years ago and deprecated for more than a decade before that.

nss-mdns should have avahi as a dependency.


Additional info:
* package version(s)
* config and/or log files etc.
* link to upstream bug report, if any
avahi 0.7+18+g1b5f401-3
nss-mdns 0.14.1-1


Steps to reproduce:
pacman -Qi avahi nss-mdns
This task depends upon

Closed by  Antonio Rojas (arojas)
Tuesday, 10 December 2019, 17:30 GMT
Reason for closing:  Fixed
Additional comments about closing:  nss-mdns 0.14.1-2

Loading...