Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#64566 - [pacman] package repo is ignored in PkgIgnore and --ignore

Attached to Project: Pacman
Opened by Dario (dario86) - Tuesday, 19 November 2019, 02:41 GMT
Last edited by morganamilo (morganamilo) - Tuesday, 19 November 2019, 02:51 GMT
Task Type Feature Request
Category General
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version 5.2.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

If multiple repos have a package with the same name, the repo from which the package is to be installed can be specified as in «pacman -S [repository name]/[package name]». However if multiple repos have a package with the same name, a package from a specific repo cannot be ignored.

Example:
I have two repos in pacman.conf: the first is [alpha] and the second is [bravo]. Both repos contain a package named «foo». I can install «foo» from [bravo] with «pacman -S bravo/foo». The problem is that if I want to ignore the same package in [alpha], the name of the repo, in this case [alpha], is ignored if you put «--ignore alpha/foo» on the command line. It is ignored in IgnorePkg as well.
This task depends upon

Closed by  morganamilo (morganamilo)
Tuesday, 19 November 2019, 02:51 GMT
Reason for closing:  Duplicate
Additional comments about closing:  See FS#20361
Comment by morganamilo (morganamilo) - Tuesday, 19 November 2019, 02:46 GMT
Depending on what exactly you use these repos for. Setting the usage level of the databases may be a workaround you can use.
Comment by Eli Schwartz (eschwartz) - Tuesday, 19 November 2019, 02:50 GMT
I'm not sure what you're trying to do here, but, the --ignore option accepts a pkgname or list of pkgnames, not a list of repository/pkgname pairs. Did you expect something different?

I'm not even sure why it would make sense to ignore a package only from one repository. If you're ignoring updates to the software it should not matter which repository level it came from. pacman will *always* only see the first candidate for the package, unless you specify pacman -S repo/pkgname or -U ./pkgfile which circumvents the usual filtering logic.

Loading...