Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64564 - [nicotine+] installing python2-mutagen (1.43.0-1) breaks dependency 'mutagen' required by nicotine+

Attached to Project: Community Packages
Opened by Eduardo Barretto (dodys) - Tuesday, 19 November 2019, 01:12 GMT
Last edited by Antonio Rojas (arojas) - Tuesday, 19 November 2019, 07:47 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Antonio Rojas (arojas)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
Python2-mutagen was updated to version 1.43.0-1 but unfortunately it is not possible to update it because it breaks dependency for nicotine+.

Additional info:
* package version(s):
* nicotine+ 1.4.1-3
* python2-mutagen 1.43.0-1

Steps to reproduce:
$ sudo pacman -S python2-mutagen
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing python2-mutagen (1.43.0-1) breaks dependency 'mutagen' required by nicotine+

This task depends upon

Closed by  Antonio Rojas (arojas)
Tuesday, 19 November 2019, 07:47 GMT
Reason for closing:  Fixed
Additional comments about closing:  nicotine+ 1.4.1-4
Comment by Dave Shoreman (dshoreman) - Tuesday, 19 November 2019, 07:33 GMT
Just came here to report the same thing. It seems nicotine+'s PKGBUILD was updated back in February to depend on `python2-mutagen`, but for some reason it's still looking for something that provides the old `mutagen` virtual package. pacman -Qi also reports "mutagen" as the dependency rather than python2-mutagen.

Since python2-mutagen was updated last night to move `mutagen` from its provides and replaces arrays, this now causes system upgrade to break unless python2-mutagen is added to `IgnorePkg` in /etc/pacman.conf.

Loading...