Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64562 - [akonadi] akonadi doesn't start after upgrading to postgresql 12.1-1

Attached to Project: Arch Linux
Opened by nl6720 (nl6720) - Monday, 18 November 2019, 21:28 GMT
Last edited by Antonio Rojas (arojas) - Monday, 18 November 2019, 22:02 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Antonio Rojas (arojas)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

After upgrading to postgresql 12.1-1 and rebooting, I saw Akonadi's automatic pg_upgrade in htop, but after pg_upgrade exited, akonadi didn't start.

Running `akonadictl start` results in:
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
org.kde.pim.akonadiserver: Starting up the Akonadi Server...
(QFileInfo(/usr/lib/postgresql/bitcode), QFileInfo(/usr/lib/postgresql/pgxs))
org.kde.pim.akonadiserver: Running DB initializer
org.kde.pim.akonadiserver: "\nSql error: ERROR: column \"version\" of relation \"schemaversiontable\" already exists\n(42701) QPSQL: Unable to create query\nQuery: ALTER TABLE SchemaVersionTable ADD COLUMN version INTEGER NOT NULL DEFAULT 0"
org.kde.pim.akonadiserver: Unable to initialize database.
waiting for server to shut down.... done
server stopped
org.kde.pim.akonadiserver: Shutting down AkonadiServer...
org.kde.pim.akonadicontrol: Application '/usr/bin/akonadiserver' exited normally...


Journal shows:
akonadiserver[1506]: org.kde.pim.akonadiserver: Cluster PG_VERSION is 11 , PostgreSQL server is version 12 , will attempt to upgrade the cluster
akonadiserver[1506]: org.kde.pim.akonadiserver: Postgres cluster upgrade: creating a new cluster for current Postgres server
akonadiserver[1506]: org.kde.pim.akonadiserver: Succesfully upgraded db cluster from Postgres 11 to 12
akonadiserver[1506]: org.kde.pim.akonadiserver: Running DB initializer
akonadiserver[1506]: org.kde.pim.akonadiserver: "\nSql error: ERROR: column \"version\" of relation \"schemaversiontable\" already exists\n(42701) QPSQL: Unable to create query\nQuery: ALTER TABLE SchemaVersionTable ADD COLUMN version INTEGER NOT NULL DEFAULT 0"
akonadiserver[1506]: org.kde.pim.akonadiserver: Unable to initialize database.
akonadiserver[1506]: org.kde.pim.akonadiserver: Failed to remove runtime connection config file
akonadiserver[1506]: org.kde.pim.akonadiserver: Shutting down AkonadiServer...
akonadi_control[1492]: org.kde.pim.akonadicontrol: Application '/usr/bin/akonadiserver' exited normally...

Additional info:
* package version(s)
* config and/or log files etc.
* link to upstream bug report, if any
akonadi 19.08.3-1
postgresql 12.1-1
postgresql-old-upgrade 11.6-1


Steps to reproduce:

Setup Akonadi with per-user PostgreSQL instance ( https://wiki.archlinux.org/index.php/KDE#Per-user_PostgreSQL_instance ),
Upgrade postgresql 11.5-7 -> 12.1-1 and postgresql-old-upgrade 10.10-3 -> 11.6-1
This task depends upon

Closed by  Antonio Rojas (arojas)
Monday, 18 November 2019, 22:02 GMT
Reason for closing:  Fixed
Additional comments about closing:  qt5-base 5.13.2-3
Comment by Antonio Rojas (arojas) - Monday, 18 November 2019, 21:48 GMT
Please test qt5-base 5.13.2-3
Comment by nl6720 (nl6720) - Monday, 18 November 2019, 22:01 GMT
With qt5-base 5.13.2-3 the issue is fixed.

From journal:
akonadiserver[4510]: org.kde.pim.akonadiserver: Starting up the Akonadi Server...
akonadiserver[4510]: (QFileInfo(/usr/lib/postgresql/bitcode), QFileInfo(/usr/lib/postgresql/pgxs))
akonadi_control[4506]: org.kde.pim.akonadicontrol: Service org.freedesktop.Akonadi.Control.lock already registered, terminating now.
akonadiserver[4510]: org.kde.pim.akonadiserver: Running DB initializer
akonadiserver[4510]: org.kde.pim.akonadiserver: DB initializer done
akonadiserver[4510]: Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
dbus-daemon[1284]: [session uid=1000 pid=1284] Successfully activated service 'org.freedesktop.Akonadi.Control'
akonadi_control[4503]: org.kde.pim.akonadicontrol: Akonadi server is now operational.

Loading...