Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64541 - [python-gobject2] broken, probably with Python 3.8

Attached to Project: Arch Linux
Opened by ryuta (ryuta) - Sunday, 17 November 2019, 06:27 GMT
Last edited by Jan Alexander Steffens (heftig) - Sunday, 17 November 2019, 15:20 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
python-gobject2 does not work anymore. I suppose it is due to Python 3.8.

Additional info:
* python-gobject2 2.28.7-3
* Python 3.8.0

Steps to reproduce:
$ python
Python 3.8.0 (default, Oct 23 2019, 18:51:26)
[GCC 9.2.0] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import gobject
Traceback (most recent call last):
File "<stdin>", line 1, in <module>
File "/usr/lib/python3.8/site-packages/gobject/__init__.py", line 26, in <module>
from glib import spawn_async, idle_add, timeout_add, timeout_add_seconds, \
File "/usr/lib/python3.8/site-packages/glib/__init__.py", line 22, in <module>
from glib._glib import *
SystemError: initialization of _glib raised unreported exception

As this library is deprecated, (Description : Python bindings for GObject (legacy)), I switched from
import gobject
to
from gi.repository import GLib
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Sunday, 17 November 2019, 15:20 GMT
Reason for closing:  Won't fix
Comment by Jan Alexander Steffens (heftig) - Sunday, 17 November 2019, 15:20 GMT
Removed python-gobject2, since we have no hard deps on it anymore. For Python 3, please use python-gobject.

Loading...