Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64496 - [kauth] kauth-policy-gen depends on icu

Attached to Project: Arch Linux
Opened by Philip Müller (philm) - Thursday, 14 November 2019, 16:01 GMT
Last edited by Eli Schwartz (eschwartz) - Thursday, 14 November 2019, 16:21 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

/usr/lib/kauth/kauth-policy-gen: error while loading shared libraries: libicui18n.so.64: cannot open shared object file: No such file or directory

Additional info:
* package version(s) 5.64.0-2

Steps to reproduce:

Try to compile an application which depends on **kauth**. It will error out. A rebuild of **kauth** against **icu** might fix it.
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Thursday, 14 November 2019, 16:21 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Wrong distro
Comment by Eli Schwartz (eschwartz) - Thursday, 14 November 2019, 16:21 GMT
$ pkg-list-linked-libraries kauth libicui18n
==> checking linked libraries for kauth-5.64.0-2-x86_64.pkg.tar.xz ...
==> ERROR: No file in kauth-5.64.0-2-x86_64.pkg.tar.xz is linked to libicui18n


This is not the Manjaro bugtracker. Fix your own repositories, ours works fine.

EDIT: I bet it is your qt5-base at fault, though. The file does link to libQt5Core.so, and...

$ pkg-list-linked-libraries qt5-base libicu
==> checking linked libraries for qt5-base-5.13.2-2-x86_64.pkg.tar.xz ...
/usr/lib/libQt5Core.so.5.13.2
NEEDED libicui18n.so.65
NEEDED libicuuc.so.65

Loading...