Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64477 - [linux-hardened] amdgpu crashes at startup

Attached to Project: Arch Linux
Opened by kevin judge (kjudge6) - Tuesday, 12 November 2019, 20:20 GMT
Last edited by Levente Polyak (anthraxx) - Tuesday, 19 November 2019, 22:32 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Levente Polyak (anthraxx)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

When reaching the point in the boot process where the simple graphics mode (that grub uses) switched to the real/high resolution mode and the getty prompt is shown, the image freezes.
According to the journal logs the boot process continues normally at that point and when the power button is pressed a normal shutdown follows. It seems however that the amdgpu driver crashed during this boot process.

When using the normal linux package on the same setup, everything works fine and no errors are found in the journal.


CPU: AMD Ryzen CPU (newest Bios version with fixed RDRAND)
GPU: RX5700 Navi 10


The most notable log findings:


kernel: amdgpu 0000:2f:00.0: overflow 0x0000800315a00000+2097152 of DMA mask fffffffffff bus mask 0
kernel: WARNING: CPU: 0 PID: 502 at kernel/dma/direct.c:35 report_addr+0x3c/0x70
...
kernel: amdgpu 0000:2f:00.0: (-14) failed to allocate kernel bo
kernel: amdgpu 0000:2f:00.0: failed to create kernel buffer for firmware.fw_buf
kernel: amdgpu 0000:2f:00.0: amdgpu_device_ip_init failed
kernel: amdgpu 0000:2f:00.0: Fatal error during GPU init
kernel: [drm] amdgpu: finishing device
kernel: WARNING: CPU: 4 PID: 502 at drivers/gpu/drm/amd/amdgpu/amdgpu_object.c:930 amdgpu_bo_unpin.cold+0x0/0x42 [amdgpu]
...
kernel: amdgpu: probe of 0000:2f:00.0 failed with error -12


In case it is relevant, a 4K/UHD Display is used.

Additional info:
* package version(s)
5.3.10.a-1


Steps to reproduce:

Boot linux-hardened, image freezes
This task depends upon

Closed by  Levente Polyak (anthraxx)
Tuesday, 19 November 2019, 22:32 GMT
Reason for closing:  Duplicate
Additional comments about closing:  FS#59463
Comment by loqs (loqs) - Tuesday, 12 November 2019, 20:45 GMT
FS#59463 ? You can check with the boot parameter mem_encrypt=off
Comment by kevin judge (kjudge6) - Tuesday, 12 November 2019, 22:25 GMT
Thats it, thank you. With mem_encrypt=off linux-hardened boots just fine.

Is this a known bug thats going to be fixed or do I need this permanently with this gpu?
Comment by loqs (loqs) - Tuesday, 12 November 2019, 23:24 GMT
[1] and [2] have not been closed as will not fix so upstream has not ruled out the possibility of fixing the issue.

[1] https://bugs.freedesktop.org/show_bug.cgi?id=104437
[2] https://bugs.freedesktop.org/show_bug.cgi?id=110929

Loading...