Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#64461 - Upgrade operation triggers Remove hooks

Attached to Project: Pacman
Opened by Andrey Vihrov (andreyv) - Monday, 11 November 2019, 19:54 GMT
Last edited by Allan McRae (Allan) - Monday, 11 November 2019, 20:08 GMT
Task Type Bug Report
Category General
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version 5.2.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Summary and Info:

When a package is upgraded/downgraded, Remove hooks are triggered. Reinstalling the same version does not trigger the hooks.

man alpm-hooks(5) does not define what a Remove operation constitutes.


Steps to Reproduce:

> pacman -S linux # Upgrade operation; triggers 60-mkinitcpio-remove.hook

...
:: Running pre-transaction hooks...
(1/1) Removing linux initcpios...
:: Processing package changes...
(1/1) upgrading linux :: Running post-transaction hooks...
...


Versions:
* pacman 5.2.1-1
* mkinitcpio 27-2
* linux 5.3.10.1-1
This task depends upon

Closed by  Allan McRae (Allan)
Monday, 11 November 2019, 20:08 GMT
Reason for closing:  Not a bug
Additional comments about closing:  pacman working as expected.
Comment by morganamilo (morganamilo) - Monday, 11 November 2019, 20:05 GMT
An upgrade is removing the old version and installing a new version.

Consider you're upgrading some DKMS package. You'd want the remove hook to trigger and remove the old version of the modules.
Comment by Allan McRae (Allan) - Monday, 11 November 2019, 20:07 GMT
This is expected...

[Trigger]
Type = File
Operation = Remove
Target = usr/lib/modules/*/vmlinuz

And files in usr/lib/modules/*/vmlinuz are being removed.

Loading...