Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64439 - [systemd] light-locker hangs on "This session is locked"

Attached to Project: Arch Linux
Opened by Renato Garcia (rgarcia) - Sunday, 10 November 2019, 04:25 GMT
Last edited by Christian Hesse (eworm) - Wednesday, 20 November 2019, 16:27 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Dave Reisner (falconindy)
Christian Hesse (eworm)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 11
Private No

Details

Description:

After locking the screen (super+l) the gui freezes on the "This session is locked" screen

Screenshot: https://imgur.com/R78OU59

Additional info:
* systemd 243.78-2
* light-locker 1.8.0-2
* Forum: https://bbs.archlinux.org/viewtopic.php?id=249053
* light-locker bug report: https://github.com/the-cavalry/light-locker/issues/146
* systemd upstream:
- bug report(closed/resolved): https://github.com/systemd/systemd/issues/13769
- Pull request: https://github.com/systemd/systemd/pull/13811

I've applied the commits and built locally based on the forum message below and it fixed the issue:
https://bbs.archlinux.org/viewtopic.php?pid=1872256#p1872256

Steps to reproduce:

After reboot the first lock/unlock works, the second ends in the freeze.
This task depends upon

Closed by  Christian Hesse (eworm)
Wednesday, 20 November 2019, 16:27 GMT
Reason for closing:  Fixed
Additional comments about closing:  systemd 243.162-2
Comment by Justin (just1602) - Wednesday, 13 November 2019, 01:31 GMT
Hello,

I have the same issue with light-locker since the last systemd update and I was wondering if there is any chance for the fix to be include in the systemd build soon?

Thanks !
Comment by Hans Ole Hatzel (hansolo) - Wednesday, 13 November 2019, 13:38 GMT
Can also confirm that cherry-picking those commits worked and didn't break anything for me in two days of usage.
Comment by André Silva (beat) - Saturday, 16 November 2019, 13:01 GMT
Would also like to confirm that I've been using these patches applied to systemd-243.78-2 for the past 3 days and the issue is gone. Everything seems to be working normally so far, no new breakage introduced.
Comment by Christian Hesse (eworm) - Wednesday, 20 November 2019, 08:27 GMT
I guess this is fixed with systemd 243.162-2?
Comment by loqs (loqs) - Wednesday, 20 November 2019, 10:43 GMT
Checking out e51d9bf9e5ac5a6618c175cd9b5cfdc6733cd5d1 I can still cherry-pick

4b9e5848e31cb2efb606a5292a2d2abb6ba35040
8cc64c2a3640121745fdfaccc6eae896ac25a911
8163b9f90079af298031dcbffee057fc344470a3
Comment by Christian Hesse (eworm) - Wednesday, 20 November 2019, 10:51 GMT
Sure... But see:

6e3cfe2e58f5dd93f66c05c74cda2879ea8a6888
dedf5b511e6fa0b5c8b70f50342e148881487287

(And 4b9e5848e31cb2efb606a5292a2d2abb6ba35040 is just cosmetic...)
Comment by André Silva (beat) - Wednesday, 20 November 2019, 11:22 GMT
Looking at the commit history from e51d9bf9e5ac5a6618c175cd9b5cfdc6733cd5d1 it seems that all relevant commits are included. I haven't tested 243.162-2 yet, but should be fixed.

Loading...