Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64407 - [musescore] Missing dependencies for musescore 3.3

Attached to Project: Community Packages
Opened by √Čloi Rivard (azmeuk) - Wednesday, 06 November 2019, 09:37 GMT
Last edited by Antonio Rojas (arojas) - Wednesday, 06 November 2019, 09:49 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

With musescore 3.3, the palettes are empty if qt5-graphicaleffects and qt5-quickcontrols2 packages are not installed.

$ mscore
Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
qrc:/qml/palettes/PalettesWidget.qml:21:1: module "QtQuick.Controls" version 2.1 is not installed
qrc:/qml/palettes/PalettesWidget.qml:47:5: Type PalettesWidgetHeader unavailable
qrc:/qml/palettes/PalettesWidgetHeader.qml:37:5: Type StyledButton unavailable
qrc:/qml/palettes/StyledButton.qml:22:1: module "QtGraphicalEffects" is not installed

Maybe the musescore package should depend on qt5-graphicaleffects and qt5-quickcontrols2?
This task depends upon

Closed by  Antonio Rojas (arojas)
Wednesday, 06 November 2019, 09:49 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#64403 

Loading...