Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64390 - Boot fails for 5.3.8-arch1-1

Attached to Project: Arch Linux
Opened by techge (techge) - Monday, 04 November 2019, 19:26 GMT
Last edited by Jan de Groot (JGC) - Tuesday, 12 November 2019, 09:52 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

After upgrading my system to linux kernel to 5.3.8-arch1-1 it fails to boot. There is nothing logged in syslog.

My setup:
Grub is decrypting the main disk on which the kernel resides (using the GRUB_ENABLE_CRYPTODISK=y option). Then the loaded kernel decrypts another disk and mounts everything. The setup is similar to this one https://www.pavelkogan.com/2014/05/23/luks-full-disk-encryption/. I don't know if it is related.

After decrypting the main disk by grub nothing happens on the screen (especially, the systemd start is not shown as it used to be) except the "slot 0 opened" message. The disk usage LED is only blinking shortly after this message.

I am using a Thinkpad x220 (sandybridge CPU).

Downgrading the kernel to 5.3.7-arch1-1 fixes the boot failure reproducibly.


This task depends upon

Closed by  Jan de Groot (JGC)
Tuesday, 12 November 2019, 09:52 GMT
Reason for closing:  Fixed
Comment by techge (techge) - Monday, 04 November 2019, 21:51 GMT
I tried 5.3.7-arch1-2, because I can not build dkms modules with 5.3.7-arch1-1. However, 5.3.7-arch1-2 fails as well, so that I think that the rebuild for newer gcc version (https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/linux&id=cb5780f58f15c7473bb6be200c22ae7dcac16952) could be connected.
Comment by Paulo Marcos de Souza Arruda do Nascimento (PMark33) - Tuesday, 05 November 2019, 20:12 GMT
I've upgraded my Asus X450LCP to this kernel version and it runs without a problem. I also have a full 256 bit LUKS encryption, with the root partition inside it. So, I don't know how can I help you for now
Comment by W Len (wlen) - Tuesday, 05 November 2019, 20:14 GMT
Similar problems with 5.3.8-arch1-1 and 5.3.7-arch1-2 on an Thinkpad X220, using LUKS for full disk encryption (although I don't think it's related). Boots to a blank screen. Pushing the power button, inserting USB-drives etc, flashes the disk light, so the system isn't fully locked, just not responsive to anything I do. Every six or seven attempts at booting it does boot fully, which leads me to believe it might be a timing issue during boot?

Downgrading to 5.3.7-arch1-1 solved it.
Comment by techge (techge) - Wednesday, 06 November 2019, 08:40 GMT
Okay, as I needed to be able to build some dkms modules, I use linux-lts now, which is working fine. As far as I can see, things break either here

https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/linux&id=cb5780f58f15c7473bb6be200c22ae7dcac16952

or (more likely) here

https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/linux&id=48fed395fd31dd9d96cde41db40bfbcfdd43464a

I am not used to build my own kernel, but I'll try to play arround with the configs a bit. I may find the problem there.
Comment by techge (techge) - Wednesday, 06 November 2019, 08:53 GMT
Okay, I guess it is just this change that is needed (regarding problems for coreboot Thinkpad users):

https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/linux&id=b25331162a46a3cd4dacfdb70c972c0a638a60ee

It is not build so far, but probably fix it.
Comment by techge (techge) - Sunday, 10 November 2019, 11:29 GMT
Issue is fixed in 5.3.9-arch1-1 currently in testing.

Loading...