Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64340 - [linux] Unable to boot kernel after upgrade from linux-5.3.7.arch1-1 to linux-5.3.7.arch1-2

Attached to Project: Arch Linux
Opened by Armin Preiml (closeneough) - Thursday, 31 October 2019, 09:29 GMT
Last edited by Jan Alexander Steffens (heftig) - Wednesday, 20 November 2019, 00:01 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The latest kernel update causes a kernel NULL pointer dereference and
made my machine unable to boot.

I upgraded from linux-5.3.7.arch1-1 to linux-5.3.7.arch1-2 including linux-headers.
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Wednesday, 20 November 2019, 00:01 GMT
Reason for closing:  Duplicate
Additional comments about closing:  Duplicate of  FS#64302 
Comment by loqs (loqs) - Thursday, 31 October 2019, 19:16 GMT
 FS#64302  ?
The 'Modules linked in' lines were truncated so I could not tell if gsmi was loaded.
Comment by Armin Preiml (closeneough) - Friday, 01 November 2019, 16:48 GMT
Of course. Added the output without truncated lines.
Comment by loqs (loqs) - Friday, 01 November 2019, 20:39 GMT
The changes between the two releases can be seen here [1]
The google changes do not appear to be relevant. Did DKMS rebuild the virtualbox modules for the update?
If you downgrade the kernel does the machine boot without issue?

[1] https://git.archlinux.org/svntogit/packages.git/log/trunk?h=packages/linux
Comment by Armin Preiml (closeneough) - Saturday, 02 November 2019, 10:17 GMT
Yes, linux 5.7.3.arch1-1 works fine after downgrading.

I tried to install 5.8.1-1 today. The machine was able to boot, but I got more of similar fails in the log. Also some modules seem to fail e.g. WLAN stopped working. This time I've attached a complete boot log.

Because you mentioned google. Following error appears

Nov 02 11:00:55 prateotu kernel: gsmi: exec 0xc1ef: Unknown error 0xc1ef
Nov 02 11:00:55 prateotu kernel: gsmi version 1.0 failed to load
Nov 02 11:00:55 prateotu kernel: gsmi: failed to load: -19
Comment by loqs (loqs) - Saturday, 02 November 2019, 17:59 GMT
If you blacklist [1] the gsmi module is the issue still present under 5.8.1-1?

[1] https://wiki.archlinux.org/index.php/Kernel_module#Blacklisting
Comment by Armin Preiml (closeneough) - Sunday, 03 November 2019, 12:34 GMT
Yes the issue is present in 5.8.1-1 and yes disabling gsmi worked! Thanks!
Comment by Jan Alexander Steffens (heftig) - Wednesday, 20 November 2019, 00:00 GMT
gsmi has already been disabled, since 5.3.9.

Loading...