Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64315 - [linux] Build failure if using an alternative values for CC= on first make step

Attached to Project: Arch Linux
Opened by John (graysky) - Tuesday, 29 October 2019, 20:41 GMT
Last edited by Jan Alexander Steffens (heftig) - Wednesday, 20 November 2019, 00:52 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

If building with `make bzImage modules CC=clang` or `make ... CC=distcc` makepkg will get held up on the `make -s image_name` step within the package function just under the "Installing boot image..." message. I believe this is due to the .config changing upon compiling bzImage. When triggered, you will be presented with the following and makepkg hangs until you ctrl+c at which point you can see some output I show below:

"install: cannot stat '*'$'\n''* Restart config...'$'\n''*'$'\n''*'$'\n''* GCC plugins'$'\n''*'$'\n''Generate some entropy during boot and runtime (GCC_PLUGIN_LATENT_ENTROPY) [N/y/?] (NEW) ': No such file or directory"

One solution is to hard-code the expected output like so:

- install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
+ install -Dm644 arch/x86/boot/bzImage "$modulesdir/vmlinuz"
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Wednesday, 20 November 2019, 00:52 GMT
Reason for closing:  Not a bug
Comment by Jan Alexander Steffens (heftig) - Wednesday, 20 November 2019, 00:51 GMT
If you override variables you need to do that everywhere. In any case, this is not an issue with our PKGBUILD.

Loading...