Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64280 - /usr/lib/libbtrfs.so.0: undefined symbol: write_raid56_with_parity

Attached to Project: Arch Linux
Opened by D.T. (MountainX) - Sunday, 27 October 2019, 01:37 GMT
Last edited by Doug Newgard (Scimmia) - Sunday, 27 October 2019, 03:05 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

/usr/lib/libbtrfs.so.0: undefined symbol: write_raid56_with_parity

* package version(s)

local/btrfs-progs 5.3.1-1
local/snap-pac 2.3.1-1
local/snapper 0.8.4-1

* config and/or log files etc.

pacman -Syu with snapper hooks gives this error:

Performing snapper post snapshots for the following configurations...
snapper: symbol lookup error: /usr/lib/libbtrfs.so.0: undefined symbol: write_raid56_with_parity
==> error: Exited due to error on line 129

pacman -Qs btrfs-progs
local/btrfs-progs 5.3-1
Btrfs filesystem utilities


* link to upstream bug report, if any

old bug report that looks similar (maybe?):
https://bugs.archlinux.org/task/51930

Steps to reproduce:

1. Install Arch on btrfs
2. Install btrfs-progs, snap-pac and snapper
3. Configure snapper todo snapshots of a btrfs subvolume
(instructions: https://wiki.archlinux.org/index.php/Snapper)
4. run "pacman -Syu"
This task depends upon

Closed by  Doug Newgard (Scimmia)
Sunday, 27 October 2019, 03:05 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#64216 

Loading...