Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64268 - [smplayer] buttons do not function with the default gui or any other gui

Attached to Project: Community Packages
Opened by Sean Lingham (Cxpher) - Friday, 25 October 2019, 19:44 GMT
Last edited by Antonio Rojas (arojas) - Thursday, 07 November 2019, 09:59 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Levente Polyak (anthraxx)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 11
Private No

Details

Description:
Launch smplayer and attempt to click on stop buttons, seek or mute/unmute, volume seek. All these buttons don't function with the default gui or any other gui. Mpv on it's own works fine.

Additional info:
* package version(s)
19.5.0-1

* config and/or log files etc.

* link to upstream bug report, if any

Steps to reproduce:

1. Launch smplayer and attempt to click on stop buttons, seek or mute/unmute, volume seek.
This task depends upon

Closed by  Antonio Rojas (arojas)
Thursday, 07 November 2019, 09:59 GMT
Reason for closing:  Fixed
Comment by Adam (adam900710) - Saturday, 26 October 2019, 00:54 GMT
Same here.

But the problem looks like the change of mpv 0.30, and SMplayer doesn't yet handle the new mpv properly.
Comment by huyizheng (huyizheng) - Saturday, 26 October 2019, 07:49 GMT
Same here.

I also think that this is caused by mpv 0.30.

Downgrade mpv back to 0.29 can temporally solve this problem.
Comment by Eimantas (eimis) - Saturday, 26 October 2019, 18:36 GMT
I reported upstream https://sourceforge.net/p/smplayer/bugs/933/

For the meanwhile I did

pacman -U https://archive.archlinux.org/packages/m/mpv/mpv-1%3A0.29.1-9-x86_64.pkg.tar.xz

and added mpv under IgnorePkg in /etc/pacman.conf
Comment by Eimantas (eimis) - Saturday, 26 October 2019, 19:37 GMT
whoops, not sure how but I messed up while testing. mpv 0.30 is already supported by the dev version. install smplayer-svn from the aur or wait until they release it
Comment by Peter Klotz (p.klotz) - Monday, 28 October 2019, 19:43 GMT
Upstream SMPlayer forum entry regarding this issue: https://forum.smplayer.info/viewtopic.php?f=2&t=12032

Fix in the SMPlayer subversion: https://app.assembla.com/spaces/smplayer/subversion/commits/9232
Comment by argo (argo_) - Monday, 28 October 2019, 20:40 GMT
It should be fixed in the freshly released version too, see https://www.smplayer.info/en/changes

Loading...