Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64249 - [gnome-control-center] 3.34.1-1 Missing runtime dependencies

Attached to Project: Arch Linux
Opened by Mathias Burén (fackamato) - Thursday, 24 October 2019, 19:50 GMT
Last edited by Antonio Rojas (arojas) - Thursday, 24 October 2019, 21:34 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: I installed gnome-control-center like so:

$ sudo pacman -S gnome-control-center
resolving dependencies...
looking for conflicting packages...

Packages (101) aalib-1.4rc5-13 accountsservice-0.6.55-1 alsa-plugins-1.1.9-2 bluez-5.51-2 bluez-libs-5.51-2 bolt-0.8-2 celt-0.11.3-3 cheese-3.34.0-2 chromaprint-1.4.3-2 clutter-1.26.2-2 clutter-gst-3.0.27-2 clutter-gtk-1.8.4-1 cogl-1.22.4-1 colord-gtk-0.2.0-1 cups-pk-helper-0.2.6-3 exiv2-0.27.2-1
faac-1.29.9.2-1 faad2-2.8.8-1 fftw-3.3.8-1 frei0r-plugins-1.6.1-7 gavl-1.4.0-3 geoclue-2.5.5-2 geocode-glib-3.26.1-1 glu-9.0.1-1 gnome-bluetooth-3.34.0+1+g96295afd-1 gnome-color-manager-3.32.0-2 gnome-desktop-1:3.34.1-1 gnome-settings-daemon-3.34.1-1 gnome-video-effects-0.5.0+4+g9554041-1
gpm-1.20.7.r27.g1fd1941-1 grilo-0.3.10-1 gsound-1.0.2-4 gssdp-1.2.1-1 gst-plugins-bad-1.16.1-2 gst-plugins-good-1.16.1-1 gupnp-1.2.1-1 gupnp-igd-0.2.5+3+gedd78a6-2 imagemagick-7.0.8.68-2 ladspa-1.15-1 libbs2b-3.1.0-6 libcaca-0.99.beta19-2 libdc1394-2.2.6-1 libdca-0.0.6-1 libde265-1.0.3-1
libdv-1.0.0-7 libdvdnav-6.0.0-1 libdvdread-6.0.1-1 libfdk-aac-2.0.1-1 libgme-0.6.2-1 libgnomekbd-3.26.1+2+g8d02ebd-1 libgtop-2.40.0+2+g31db82ef-1 libgweather-3.34.0-1 libhandy-0.0.11-1 libical-3.0.6-1 liblqr-0.4.2-2 liblrdf-0.6.1-3 libmm-glib-1.10.6-1 libmms-0.6.4-2 libmp4v2-2.0.0-5
libmpcdec-1:0.1+r475-2 libmpeg2-0.5.1-6 libnice-0.1.16-1 libnm-1.20.4-1 libnma-1.8.24-1 libofa-0.9.3-8 libpwquality-1.4.1-1 libquvi-0.9.4-5 libquvi-scripts-0.9.20131130-4 libraqm-0.7.0-1 libshout-1:2.4.3-1 libsrtp-1:2.2.0-1 libxklavier-5.4-2 lua52-5.2.4-4 lua52-bitop-1.0.2-8
lua52-expat-1.3.0-4 lua52-lpeg-1.0.2-1 lua52-luajson-1.3.4-2 lua52-socket-20190219-1 mjpegtools-2.1.0-4 mobile-broadband-provider-info-20190618-1 mpg123-1.25.12-1 neon-0.30.2-3 nm-connection-editor-1.8.24-1 openexr-2.4.0-4 pulseaudio-alsa-2-5 pulseaudio-bluetooth-13.0-2 raptor-2.0.15-11
sbc-1.4-1 sdl-1.2.15-13 shared-color-targets-0.1.7-2 soundtouch-2.1.2-1 spandsp-0.0.6-2 srt-1.4.0-1 taglib-1.11.1-3 totem-plparser-3.26.3-1 twolame-0.4.0-1 wavpack-5.1.0-2 wildmidi-0.4.3-1 zbar-0.23-1 zvbi-0.2.35-3 gnome-control-center-3.34.1-1

Attempting to launch gnome-control-center results in an error:

$ gnome-control-center

(gst-plugin-scanner:15336): GStreamer-WARNING **: 12:46:25.063: Failed to load plugin '/usr/lib/gstreamer-1.0/libgstkate.so': libkate.so.1: cannot open shared object file: No such file or directory

(gst-plugin-scanner:15336): GStreamer-WARNING **: 12:46:25.182: Failed to load plugin '/usr/lib/gstreamer-1.0/libgstfluidsynthmidi.so': libfluidsynth.so.2: cannot open shared object file: No such file or directory

(gst-plugin-scanner:15336): GStreamer-WARNING **: 12:46:25.277: Failed to load plugin '/usr/lib/gstreamer-1.0/libgstqmlgl.so': libQt5WaylandClient.so.5: cannot open shared object file: No such file or directory

(gst-plugin-scanner:15336): GStreamer-WARNING **: 12:46:25.279: Failed to load plugin '/usr/lib/gstreamer-1.0/libgstlv2.so': liblilv-0.so.0: cannot open shared object file: No such file or directory
**
ERROR:../gnome-control-center/shell/cc-shell-model.c:458:cc_shell_model_set_panel_visibility: assertion failed: (valid)
Bail out! ERROR:../gnome-control-center/shell/cc-shell-model.c:458:cc_shell_model_set_panel_visibility: assertion failed: (valid)
Aborted (core dumped)
This task depends upon

Closed by  Antonio Rojas (arojas)
Thursday, 24 October 2019, 21:34 GMT
Reason for closing:  Not a bug
Comment by Antonio Rojas (arojas) - Thursday, 24 October 2019, 20:01 GMT
The crash has nothing to do with any missing dependencies (which are all optdepends of gstreamer)

Are you trying to run it outside of gnome?
Comment by Mathias Burén (fackamato) - Thursday, 24 October 2019, 20:23 GMT
You are correct, they are just warnings unrelated to the crash. Yes, I am trying to run this under LXDE. The GNOME devs could certainly provide a useful error message in these scenarios.

As this is expected, I suppose we can close this as a non-issue.

Loading...