Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64236 - [archiso] cannot build baseline iso

Attached to Project: Arch Linux
Opened by Wilson E. Alvarez (Rubonnek) - Wednesday, 23 October 2019, 22:20 GMT
Last edited by freswa (frederik) - Saturday, 01 August 2020, 19:31 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Pierre Schmitz (Pierre)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description:
Attempting to make the baseline ISO does not work due to missing mkinitcpio (and possibly other packages)

Additional info:
* package version(s): 43-1
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:
cp -rv /usr/share/archiso/configs/baseline/ $HOME
cd $HOME/baseline
./build.sh -v
This task depends upon

Closed by  freswa (frederik)
Saturday, 01 August 2020, 19:31 GMT
Reason for closing:  Fixed
Additional comments about closing:  archiso 46-1
Comment by Angus McInnes (jib) - Thursday, 12 March 2020, 09:40 GMT
Adding a line to build.sh of the baseline profile makes it work:

```
make_basefs() {
mkarchiso -v -w "${work_dir}" -D "${install_dir}" init
mkarchiso -v -w "${work_dir}" -D "${install_dir}" -p "mkinitcpio linux" install
}
```
Comment by archlinux user (archlinux-user) - Saturday, 23 May 2020, 13:32 GMT
Thanks for the workaround, Angus. I can confirm it works. The baseline iso was created successfully after that. I wasn't able to login, though. I tried to login as "root", using "root" as the password, but it did not work.

Loading...