Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64225 - [java-openjfx] Gradle 5.6+ breaks the build (resources missing)

Attached to Project: Arch Linux
Opened by Ilya Lipnitskiy (lipnitsk) - Wednesday, 23 October 2019, 00:20 GMT
Last edited by freswa (frederik) - Sunday, 13 September 2020, 14:08 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Guillaume ALAUX (galaux)
Maxime Gauduin (Alucryd)
Levente Polyak (anthraxx)
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

See upstream https://bugs.openjdk.java.net/browse/JDK-8226754 and https://github.com/openjdk/jfx/commit/64aaeb840aa157e358eb41001c3705aa5c2fee30

Attaching java-openjfx-gradle.patch that applies the change above to Arch.

Note that ant 1.10.7 also breaks build (see https://bugs.archlinux.org/task/64055 and https://bz.apache.org/bugzilla/show_bug.cgi?id=63874). Downgrading to ant 1.10.6 is required to build java-openjfx.
This task depends upon

Closed by  freswa (frederik)
Sunday, 13 September 2020, 14:08 GMT
Reason for closing:  Fixed
Additional comments about closing:  Builds fine now
Comment by Ilya Lipnitskiy (lipnitsk) - Wednesday, 23 October 2019, 00:22 GMT
This patch applies the change and fixes up PKGBUILD.
Comment by Chigozirim Chukwu (FirstAirBender) - Monday, 02 March 2020, 23:04 GMT
I don't know if this is related, but using this package does not work when running JavaFX applications because it is missing resources.

I get the following error:

```java
Caused by: java.util.MissingResourceException: Can't find bundle for base name com.sun.javafx.tk.quantum.QuantumMessagesBundle, locale en_CA
at java.base/java.util.ResourceBundle.throwMissingResourceException(ResourceBundle.java:2055)
at java.base/java.util.ResourceBundle.getBundleImpl(ResourceBundle.java:1689)
at java.base/java.util.ResourceBundle.getBundleImpl(ResourceBundle.java:1582)
at java.base/java.util.ResourceBundle.getBundleImpl(ResourceBundle.java:1556)
at java.base/java.util.ResourceBundle.getBundle(ResourceBundle.java:932)
at javafx.graphics/com.sun.javafx.tk.quantum.WindowStage.<clinit>(WindowStage.java:101)
```
Comment by Ilya Lipnitskiy (lipnitsk) - Monday, 23 March 2020, 20:13 GMT

Loading...