Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64223 - [linux] Nouveau crashes on suspend; PAGE_NOT_PRESENT

Attached to Project: Arch Linux
Opened by Sandy (Sandy) - Tuesday, 22 October 2019, 21:59 GMT
Last edited by freswa (frederik) - Monday, 16 March 2020, 15:26 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
When I close my laptop and open it, it freezes; everything on screen (like clock) stops moving and keyboard/touchpad stop responding.
According to journal:
paź 22 22:24:53 Langley kernel: nouveau 0000:01:00.0: fifo: write fault at 0000048000 engine 07 [PFIFO] client 07 [BAR_READ] reason 02 [PAGE_NOT_PRESENT] on channel 2 [003fc13000 Xorg[465]]
paź 22 22:24:53 Langley kernel: nouveau 0000:01:00.0: fifo: fifo engine fault on channel 2, recovering...
(don't mind Polish month)

I am using Sony Vaio (VPCEH2D1E C1065BHW) which has NVIDIA GeForce 410M; kernel version is 5.3.7. All packages should be updated.

Additional info:
* Kernel: 5.3.7-arch1-1-ARCH
* Journalctl attached

Steps to reproduce:
1. Close laptop and wait a few seconds so it suspends
2. Open it
I suppose you need a similar/same model for this bug to work
This task depends upon

Closed by  freswa (frederik)
Monday, 16 March 2020, 15:26 GMT
Reason for closing:  No response
Comment by loqs (loqs) - Tuesday, 22 October 2019, 23:40 GMT
Please read through https://nouveau.freedesktop.org/wiki/Bugs/ and looked through similar bug reports on https://bugs.freedesktop.org/ under Product xorg Category Driver/nouveau
and if your bug is distinct file a new report on that bug tracker. You could also check linux 5.4-rc4 to see if the issue is already fixed.
Comment by Jochum (jooch) - Friday, 27 December 2019, 23:46 GMT
I can confirm this bug, same problem here (desktop with 9500GT).

@loqs
URL was moved to: https://gitlab.freedesktop.org/xorg/driver/xf86-video-nouveau/issues

Temporary solution:
Install/run linux-lts

Comment by loqs (loqs) - Friday, 27 December 2019, 23:55 GMT
Thank you for reporting the issue upstream Sandy
https://gitlab.freedesktop.org/xorg/driver/xf86-video-nouveau/issues/511

Is the issue still present under line 5.5-rc3? (available from https://wiki.archlinux.org/index.php/Unofficial_user_repositories#miffe in the linux-mainline package)

Loading...