Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64204 - [mutter] CAP_SYS_NICE not strictly needed for realtime scheduling support on Wayland

Attached to Project: Arch Linux
Opened by helle vaanzinn (glitsj16) - Monday, 21 October 2019, 18:22 GMT
Last edited by freswa (frederik) - Friday, 21 February 2020, 23:06 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
To enable realtime scheduling support for gnome-shell on Wayland it isn't necessary to set CAP_SYS_NICE on /usr/bin/mutter. It suffices to do that for /usr/bin/gnome-shell.

Additional info:
* package version(s)
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:
Enable realtime scheduling:
$ gsettings set org.gnome.mutter experimental-features "['rt-scheduler']"
Remove CAP_SYS_NICE from mutter binary:
$ sudo setcap CAP_SYS_NICE=-ep usr/bin/mutter
Reboot/Re-login (using Alt+F2 doesn't work on Wayland)
Check realtime scheduling support:
$ ps -C gnome-shell -Lo pid,cls,comm,command
1179 RR gnome-shell /usr/bin/gnome-shell
1179 TS gmain /usr/bin/gnome-shell
1179 TS gdbus /usr/bin/gnome-shell
1179 TS dconf worker /usr/bin/gnome-shell
1179 IDL gnome-s:disk$0 /usr/bin/gnome-shell
1179 TS JS Helper /usr/bin/gnome-shell
1179 TS JS Helper /usr/bin/gnome-shell

I suppose the relevant dconf key being named org.gnome.mutter causes confusion in this context.
In any case, this doesn't keep gnome-shell from being able to run with realtime scheduling support, but it doesn't seem strictly necessary to set CAP_SYS_NICE for mutter.
This task depends upon

Closed by  freswa (frederik)
Friday, 21 February 2020, 23:06 GMT
Reason for closing:  Not a bug
Comment by Jan Alexander Steffens (heftig) - Friday, 21 February 2020, 21:51 GMT
This was quite deliberate. Bare mutter can use realtime scheduling as well.
Comment by helle vaanzinn (glitsj16) - Friday, 21 February 2020, 23:05 GMT
@heftig Thanks for the explanation, makes perfect sense.

Loading...