Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64194 - [libxkbcommon] gnome-shell fails to start because of segfault in libxkbcommon

Attached to Project: Arch Linux
Opened by Stephan Windmüller (windy) - Sunday, 20 October 2019, 19:44 GMT
Last edited by Antonio Rojas (arojas) - Sunday, 20 October 2019, 20:11 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

After upgrading libxkbcommon to 0.9.0-1, Gnome did not start after a reboot. The log messages are:

gnome-shell[822]: xkbcommon: ERROR: failed to add default include path /usr/share/X11/xkb
kernel: gnome-shell[822]: segfault at 0 ip 00007f797e583eb0 sp 00007ffd6c703498 error 6 in libxkbcommon.so.0.0.0[7f797e57a000+1b000]

Downgrading to 0.8.4-1 fixed the problem.
This task depends upon

Closed by  Antonio Rojas (arojas)
Sunday, 20 October 2019, 20:11 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#64191 
Comment by Jonas Malaco Filho (jonasmalaco) - Sunday, 20 October 2019, 20:00 GMT
Duplicate of  FS#64191 .

Loading...