Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64186 - [kscreenlocker] random crash when woke up from screensaver, have to use loginctl to unlock

Attached to Project: Arch Linux
Opened by Adam (adam900710) - Sunday, 20 October 2019, 08:59 GMT
Last edited by Antonio Rojas (arojas) - Saturday, 26 October 2019, 08:21 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Antonio Rojas (arojas)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

Kscreenlocker randomly crashes.

With dmesg catching the crash:
[18918.178253] kscreenlocker_g[10816]: segfault at 7ffbff7fdf60 ip 00007efbfe417558 sp 00007ffbff7fdf30 error 6 in libQt5Gui.so.5.13.1[7efbfe0a6000+414000]
[18918.178259] Code: e5 40 e9 6b ff ff ff 90 66 2e 0f 1f 84 00 00 00 00 00 41 57 41 56 41 55 41 54 55 53 48 89 fb 48 81 ec c8 38 00 00 48 8b 6f 10 <48> 89 74 24 30 64 48 8b 04 25 28 00 00 00 48 89 84 24 b8 38 00 00

Additional info:
* package version(s)
extra/kscreenlocker 5.17.0-1
extra/qt5-base 5.13.1-2
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:
- Use plasma on X11
- Wait for screenlocker to kick in or manually lock current seesion
- Several blank flashes, and message indicating the kscreenlocker is down, have to use loginctl to unlock
This task depends upon

Closed by  Antonio Rojas (arojas)
Saturday, 26 October 2019, 08:21 GMT
Reason for closing:  Fixed
Comment by Antonio Rojas (arojas) - Sunday, 20 October 2019, 09:16 GMT
Are you using a slideshow in your lock screen?
Comment by Adam (adam900710) - Sunday, 20 October 2019, 09:40 GMT
Nope, just plain lock screen.

The screen saver is just a picture, and that part works fine.

Only kscreenlocker crashed.
Comment by Antonio Rojas (arojas) - Sunday, 20 October 2019, 09:41 GMT
Please post a full backtrace
Comment by Adam (adam900710) - Sunday, 20 October 2019, 09:49 GMT
Strangely, coredumpctl failed to catch that crash.
Thus no backtrace available.

Just interested no one else hit such crash.
Comment by Adam (adam900710) - Sunday, 20 October 2019, 09:58 GMT
BTW, my desktop and laptop all have the same problem, thus it shouldn't be that rare, especially my laptop has far less customization compared to my desktop.
Comment by Adam (adam900710) - Sunday, 20 October 2019, 10:04 GMT
Extra info:
Further looking into the journal, it looks like kscreenlocker_greeter is trying to add a lot of inotify.
I have a kernel source code which has a loop soft link, and limited inotify max.
So it kscreenlocker_greeter will easily hit ENOSPC when adding inotify.

Not sure why this happens.

17:07:37 adam-pc ksmserver[2259]: UnmapNotify: 140509215
17:07:37 adam-pc ksmserver[2259]: UnmapNotify: 140509219
17:07:37 adam-pc ksmserver[2259]: CreateNotify: 140509188
17:07:37 adam-pc ksmserver[2259]: CreateNotify: 140509192
17:07:37 adam-pc ksmserver[2259]: CreateNotify: 140509201
17:07:37 adam-pc kscreenlocker_greet[12230]: inotify_add_watch(/home/adam/.config/plasmarc) failed: (No space left on device)
17:07:37 adam-pc ksmserver[2259]: CreateNotify: 140509202
17:07:37 adam-pc ksmserver[2259]: CreateNotify: 140509204
17:07:37 adam-pc ksmserver[2259]: MapNotify: 140509202
17:07:37 adam-pc ksmserver[2259]: CreateNotify: 140509205
17:07:37 adam-pc ksmserver[2259]: MapNotify: 140509205
17:07:37 adam-pc kscreenlocker_greet[12230]: inotify_add_watch(/usr/share/plasma/desktoptheme/Arc-Dark/metadata.desktop) failed: (No space left on device)
17:07:37 adam-pc kscreenlocker_greet[12230]: inotify_add_watch(/usr/share/icons/Papirus-Dark/index.theme) failed: (No space left on device)
17:07:37 adam-pc kscreenlocker_greet[12230]: inotify_add_watch(/etc/fstab) failed: (No space left on device)
17:07:37 adam-pc ksmserver[2259]: CreateNotify: 140509214
17:07:38 adam-pc ksmserver[2259]: CreateNotify: 140509229
17:07:38 adam-pc org_kde_powerdevil[2313]: powerdevil: Scheduling inhibition from ":1.16" "My SDL application" with cookie 273 and reason "Playing a game"
17:07:38 adam-pc org_kde_powerdevil[2313]: powerdevil: Releasing inhibition with cookie 273
17:07:38 adam-pc org_kde_powerdevil[2313]: powerdevil: It was only scheduled for inhibition but not enforced yet, just discarding it
17:07:39 adam-pc kernel: kscreenlocker_g[12230]: segfault at 7ffbff7fdfe0 ip 00007efbfe417558 sp 00007ffbff7fdfb0 error 6 in libQt5Gui.so.5.13.1[7efbfe0a6000+414000]
17:07:39 adam-pc kernel: Code: e5 40 e9 6b ff ff ff 90 66 2e 0f 1f 84 00 00 00 00 00 41 57 41 56 41 55 41 54 55 53 48 89 fb 48 81 ec c8 38 00 00 48 8b 6f 10 <48> 89 74 24 30 64 48 8b 04 25 28 00 00 00 48 >gg
Comment by Antonio Rojas (arojas) - Sunday, 20 October 2019, 10:07 GMT
can you post your kscreenlockerrc
Comment by Adam (adam900710) - Sunday, 20 October 2019, 10:17 GMT
[$Version]
update_info=kscreenlocker.upd:0.1-autolock

[Greeter]
Theme=com.github.varlesh.arc-dark

[Greeter][Wallpaper][org.kde.image][General]
Image=file:///home/adam/wallpapers/wallpaler.jpg
Comment by mat (cyanin) - Monday, 21 October 2019, 06:09 GMT
Just want to chime in, I'm seeing this exact issue. It appears to happen randomly? Was doing it nonstop last night, across reboots, this morning it doesn't want to. When it does happen the screen flashes black about 3 times, 5-10 seconds into the screen lock.

- This is a fresh install
- kscreenlockerrc is the same as adam's (wallpaper is a static image, only difference is I'm using breezedark theme)
- Tried playing with lock password time settings, same result regardless of that.

Dmesg spams what looks like the same thing when it happens:
kscreenlocker_g[21533]: segfault at 7ffd779e2fc0 ip 00007fd3c1c8e558 sp 00007ffd779e2f90 error 6 in libQt5Gui.so.5.13.1[7fd3c191d000+414000]
[11358.319064] Code: e5 40 e9 6b ff ff ff 90 66 2e 0f 1f 84 00 00 00 00 00 41 57 41 56 41 55 41 54 55 53 48 89 fb 48 81 ec c8 38 00 00 48 8b 6f 10 <48> 89 74 24 30 64 48 8b 04 25 28 00 00 00 48 89 84 24 b8 38 00 00

Due to weekday work I won't be able to respond to anything new very often.
Comment by Antonio Rojas (arojas) - Wednesday, 23 October 2019, 08:07 GMT
status with 5.17.1?
Comment by mat (cyanin) - Wednesday, 23 October 2019, 17:44 GMT
Wow, that was fast. I'm not seeing it happen so far, though I've only had a bit to test it. The locker seems a lot more responsive in general. Will update if I see it starting again.
Comment by Adam (adam900710) - Saturday, 26 October 2019, 08:20 GMT
Haven't see the bug any more since upgraded to .1

Upstream also said .1 would solve it. So I'll close the case.

Loading...