Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64184 - Kernel from linux 5.3.6.arch1-1 package does not boot on Intel Atom 330 (D945GCLF2 mobo)

Attached to Project: Arch Linux
Opened by Max Pray (synthead) - Saturday, 19 October 2019, 19:54 GMT
Last edited by freswa (frederik) - Saturday, 25 April 2020, 14:04 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To No-one
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

When upgrading the linux package to 5.3.6.arch1-1 on an Intel Atom 330 system with an Intel D945GCLF2 motherboard, the system halts during boot before the initrd is loaded. No error messages are displayed (except an IRQ BIOS error that has been non-fatal for years).

Because of difficulties obtaining a text log for this problem, here are some pictures of a monitor attached to the system: https://imgur.com/a/VKwRkT6. The first image is the system frozen with unmodified boot parameters:

linux /boot/vmlinuz-linux rw init=/usr/lib/systemd/systemd root=UUID=<uuid> acpi=off

The second one is with loglevel=7 appended:

linux /boot/vmlinuz-linux rw init=/usr/lib/systemd/systemd root=UUID=<uuid> acpi=off loglevel=7

The last known kernel to work is in the package linux 5.1.15.arch1-1. I have also attempted linux-lts kernel 4.19.79-2 and the same issues are equally reproduced.

Steps to reproduce:

1. Prepare an Intel D945GCLF2 (with an Atom 330 CPU) with up-to-date packages except the linux package, which should be downgraded to version 5.1.15.arch1-1.
2. Upgrade the kernel to 5.3.6.arch1-1.
3. Reboot.
4. Observe that the system locks up when attempting to boot.
This task depends upon

Closed by  freswa (frederik)
Saturday, 25 April 2020, 14:04 GMT
Reason for closing:  No response
Comment by loqs (loqs) - Saturday, 19 October 2019, 23:25 GMT
No 5.2 series kernel worked? Did any 4.19 series kernel work?
Comment by Max Pray (synthead) - Thursday, 24 October 2019, 21:57 GMT
I upgraded the linux package from the ALA until the system refused to boot. The latest working kernel is from the 5.3.2.arch1-1 package. There appears to be no 5.3.3 version, but the 5.3.4 version does not boot in the same fashion as the latest standard and LTS kernel.
Comment by loqs (loqs) - Thursday, 24 October 2019, 23:17 GMT
If the issue is till present in 5.3.7 you can either test 5.4-rc4 using [1] to see if the issue has already been fixed
or bisect between 5.3.2 and 5.3.4 to locate the causal commit. 5.3.2.bisect.txt provides step by step instructions for the bisection.
The provided src.tar.gz allows you to skip to line 9 then skip line 10 as the bundle is already adjusted then continue with line 11.

[1] https://aur.archlinux.org/packages/linux-mainline
Comment by Max Pray (synthead) - Tuesday, 31 March 2020, 21:44 GMT
  • Field changed: Percent Complete (100% → 0%)
Was out of town for an extended period of time! I upgraded to 5.5.13.arch1-1 and this issue is still present :(
Comment by Max Pray (synthead) - Tuesday, 31 March 2020, 22:42 GMT
Downgrading to linux 5.3.2.arch1-1 still makes the system boot, and there aren't any dependency problems with this older version as of this writing.
Comment by loqs (loqs) - Thursday, 02 April 2020, 19:38 GMT
How are you progressing with the git bisection between 5.3.2 and 5.3.4?

Loading...