Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64182 - [libglvnd] Recent changes break packages from building

Attached to Project: Arch Linux
Opened by John (graysky) - Saturday, 19 October 2019, 19:13 GMT
Last edited by Laurent Carlier (lordheavy) - Friday, 25 October 2019, 07:28 GMT
Task Type Bug Report
Category Upstream Bugs
Status Assigned
Assigned To Laurent Carlier (lordheavy)
Felix Yan (felixonmars)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 3
Private No

Details

The recent bumps to both mesa and libglvnd causes kodi to break during its build. I am not sure what is best to fix, either disable libglvnd headers and ship mesa's or patch libglvnd headers to provide missing stuff could be options. Perhaps there is a better way.

Additional info:
* package version(s): mesa-19.2.1-2 and libglvnd 1.2.0-3

Steps to reproduce:
Try to build kodi in a buildroot. Link to building kodi-18.4-3 (containing the error): https://gist.github.com/graysky2/de6d243822039d27b22186ee79ffde47
This task depends upon

Comment by loqs (loqs) - Sunday, 20 October 2019, 01:16 GMT
Test to see if everything required is still present only the headers providing it are different.
cmake/modules/FindOpenGLES.cmake is not detecting opengles so HAS_GLES is not defined
Comment by John (graysky) - Sunday, 20 October 2019, 11:19 GMT
@loqs - If build kodi applying your patch, it completes without errors. Link to kodi-18.4-3-x86_64-build.log using it: https://gist.github.com/graysky2/695557779aabf15d222edb193ac2493e
Comment by Laurent Carlier (lordheavy) - Sunday, 20 October 2019, 13:20 GMT
It's a libglvnd bug, gl.h provided is out of date. Replacing with latest header from previous mesa release fixes the issue.
Comment by Hussam Al-Tayeb (hussam) - Sunday, 20 October 2019, 13:38 GMT
That sounds easy enough. I will try here.
Comment by Laurent Carlier (lordheavy) - Sunday, 20 October 2019, 15:26 GMT Comment by John (graysky) - Sunday, 20 October 2019, 15:42 GMT
@Laurent - You are right. Manually replacing gl.h in the buildroot allows for a successful build.
Comment by Laurent Carlier (lordheavy) - Wednesday, 23 October 2019, 08:34 GMT
Please test with libglvnd-1.2.0-4 in testing - do not hesitate to test with other packages
Comment by John (graysky) - Wednesday, 23 October 2019, 23:07 GMT
I built kodi-x11 with [testing] enabled. Thanks for the quick turnaround.
Comment by Hussam Al-Tayeb (hussam) - Thursday, 24 October 2019, 05:45 GMT
This may be unrelated but I am getting Dependency gl found: NO found '1.2' but need: '>= 9.2.0'
in another application.
libglvnd /usr/lib/pkgconfig/gl.pc
The Version entry says 1.2
Comment by Laurent Carlier (lordheavy) - Friday, 25 October 2019, 07:10 GMT
@Hussam which package?

pushed libglvnd-1.2.0-5 with more fixes - and fixed xorg-server-1.20.5 building failures
Comment by Hussam Al-Tayeb (hussam) - Friday, 25 October 2019, 07:22 GMT
It was indeed xorg-server. I wanted to make sure not much broke.
And I just noticed you pushed updates to both libglvnd and xorg-server with fixes.
Thank you.
Comment by Laurent Carlier (lordheavy) - Friday, 25 October 2019, 07:28 GMT
sdl2 and qt5 need to be fixed too - because they use MESA_EGL_NO_X11_HEADERS definition - to be changed with EGL_NO_X11
Comment by Hussam Al-Tayeb (hussam) - Sunday, 03 November 2019, 12:28 GMT
Comment by Laurent Carlier (lordheavy) - Monday, 04 November 2019, 10:53 GMT
@hussam

Good catch!

Loading...