Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64181 - [python-cheroot] missing dependency jaraco.functools

Attached to Project: Community Packages
Opened by Kirill Goncharov (xuhcc) - Saturday, 19 October 2019, 16:45 GMT
Last edited by Thore Bödecker (foxxx0) - Thursday, 21 November 2019, 14:16 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Thore Bödecker (foxxx0)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:

It looks like python-cheroot now have new dependency: https://github.com/jaraco/jaraco.functools
I get the following error:

File "/usr/lib/python3.7/site-packages/cheroot/wsgi.py", line 36, in <module>
from . import server
File "/usr/lib/python3.7/site-packages/cheroot/server.py", line 90, in <module>
from .workers import threadpool
File "/usr/lib/python3.7/site-packages/cheroot/workers/threadpool.py", line 15, in <module>
from jaraco.functools import pass_none
ModuleNotFoundError: No module named 'jaraco'


Additional info:
* package version: 8.2.0-1
This task depends upon

Closed by  Thore Bödecker (foxxx0)
Thursday, 21 November 2019, 14:16 GMT
Reason for closing:  Fixed
Additional comments about closing:  fixed as of python-cheroot 8.2.1-4
Comment by Kirill Goncharov (xuhcc) - Sunday, 27 October 2019, 21:14 GMT Comment by Rafael Fontenelle (josephg) - Sunday, 03 November 2019, 19:36 GMT
 FS#64342  is a duplicate of this, but has steps to reproduce this. Hope it helps.

Loading...