Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64077 - libx11 causes file conflict error during upgrade

Attached to Project: Arch Linux
Opened by Martin Schmidt (Blind) - Wednesday, 09 October 2019, 18:33 GMT
Last edited by Levente Polyak (anthraxx) - Wednesday, 09 October 2019, 18:34 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
upgrading to libx11 (1.6.9-1) causes an error due to a file conflict:

Additional info:
* package version(s)
installed: 1.6.8-1
upgrade version: 1.6.9-1

* config and/or log files etc.
error: failed to commit transaction (conflicting files)
libx11: /usr/include/X11/extensions/XKBgeom.h exists in filesystem (owned by xorgproto)
Errors occurred, no packages were upgraded.

* link to upstream bug report, if any
n/a

Steps to reproduce:
have libx11 1.6.8-1 installed.
pacman -Syu will attempt to update to 1.6.9-1, and will throw a file conflict error.
This task depends upon

Closed by  Levente Polyak (anthraxx)
Wednesday, 09 October 2019, 18:34 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#64076 

Loading...