Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64040 - [seahorse] PGP key import not working / package pinentry-gnome3 missing

Attached to Project: Arch Linux
Opened by Master One (MasterOne) - Sunday, 06 October 2019, 15:15 GMT
Last edited by Antonio Rojas (arojas) - Tuesday, 08 October 2019, 16:52 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Currently it is not possible to import PGP keys using Gnome Seahorse likely because there is no package called pinentry-gnome3 (it's also not in AUR), that other distributions have, like here for Debian:

https://packages.debian.org/sid/utils/pinentry-gnome3

So the problem is, when selecting a PGP key to be imported, it first shows the key data, but importing fails without any error message as the box for entering the passphrase never comes up. Importing a key in console works.

Additional info:

Tested with extra/seahorse 1:3.34-1

Steps to reproduce:

Try to import a PGP key.
This task depends upon

Closed by  Antonio Rojas (arojas)
Tuesday, 08 October 2019, 16:52 GMT
Reason for closing:  Not a bug
Comment by Antonio Rojas (arojas) - Sunday, 06 October 2019, 15:31 GMT
pacman -Qkk pinentry?
Comment by Master One (MasterOne) - Sunday, 06 October 2019, 15:37 GMT
@arojas, already checked, the pinentry-gnome3 binary is present, so this was a wrong assumption. It's not working as described nonetheless, so this may be an upstream issue instead.

Loading...