Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64039 - [seahorse] Compiled with LDAP key server support only / can not add HKP key server

Attached to Project: Arch Linux
Opened by Master One (MasterOne) - Sunday, 06 October 2019, 15:08 GMT
Last edited by freswa (frederik) - Friday, 21 February 2020, 21:59 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

It does not seem to be possible to add a HKP key server, the drop-down for type of key server only offers "LDAP key server" and in a fresh Arch Linux installation with Gnome only ldap://keyserver.pgp.com is configured, although the default should be

hkp://pool.sks-keyservers.net
ldap://keyserver.pgp.com

according to this web page: https://help.gnome.org/users/seahorse/stable/key-servers-add.html.en

Additional info:

Has been checked with package extra/seahorse 1:3.34-1

Steps to reproduce:

Check configured key servers and try to add one.
This task depends upon

Closed by  freswa (frederik)
Friday, 21 February 2020, 21:59 GMT
Reason for closing:  Not a bug
Comment by Master One (MasterOne) - Wednesday, 09 October 2019, 15:47 GMT
Further investigation revealed that the problem is the default configuration only containing ldap://keyserver.pgp.com as configured key server, which makes it impossible to add a hpk server address using the Seahorse configuration GUI.

Inserting a hpk server address using dconf-editor solved that problem.

The solution would be to include a configuration with at least one ldap and one hkp key server configured.

Loading...