Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64025 - [matrix-synapse] fails to start after 1.4 update

Attached to Project: Community Packages
Opened by mike (mbalajew) - Saturday, 05 October 2019, 17:27 GMT
Last edited by Johannes Löthberg (demize) - Sunday, 03 November 2019, 16:10 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Johannes Löthberg (demize)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description: `systemctl status synapse` returns:

Oct 05 13:21:14 archVPS systemd[1]: Started Synapse Matrix homeserver.
Oct 05 13:21:14 archVPS systemd[540]: synapse.service: Changing to the requested working directory failed: No such file or directory
Oct 05 13:21:14 archVPS systemd[540]: synapse.service: Failed at step CHDIR spawning /usr/bin/python3.7: No such file or directory
Oct 05 13:21:14 archVPS systemd[1]: synapse.service: Main process exited, code=exited, status=200/CHDIR
Oct 05 13:21:14 archVPS systemd[1]: synapse.service: Failed with result 'exit-code'.

Steps to reproduce:
1) attempt to start service: `sudo systemctl start synapse`
This task depends upon

Closed by  Johannes Löthberg (demize)
Sunday, 03 November 2019, 16:10 GMT
Reason for closing:  Fixed
Additional comments about closing:  Missing tmpfiles.d conf added in 1.5.0
Comment by mike (mbalajew) - Saturday, 05 October 2019, 17:37 GMT
I should add that synapses starts without errors after downgrading to 1.3.1-1
Comment by Danny (houtworm) - Tuesday, 08 October 2019, 01:01 GMT
The problem is the working directory line in the synapse.service file, If you comment it out the service starts and works like normal again.
Comment by mike (mbalajew) - Tuesday, 08 October 2019, 01:54 GMT
Great, should I just go ahead and email the maintainer?
Comment by Danny (houtworm) - Tuesday, 08 October 2019, 02:15 GMT
I think he gets an email if we comment here, Not sure tho.

Loading...