Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64015 - battery drain with kernels linux-5.3.2 and linux-zen-5.3.2

Attached to Project: Arch Linux
Opened by Antonio Corbi bellot (acorbi) - Friday, 04 October 2019, 13:53 GMT
Last edited by freswa (frederik) - Friday, 21 February 2020, 21:58 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To No-one
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

This is an update to a bug repoert I opened october 2nd in the wrong cathegory.

I also took the time to update it due to new kernel versions installed today.

With linux 5.3.2-arch2-1 and linux-zen 5.3.2-zen1-2 the laptop battery lasts for (approx.) half of the time than wit linux-lts 4.19.76-2-lts.
Some rough measures taken with the acpi command:

- linux-lts 4.19.76-2-lts: Battery 0: Discharging, 79%, 04:25:02 remaining
- linux 5.3.2-arch2-1-ARCH: Battery 0: Discharging, 79%, 02:31:29 remaining
- linux-zen 5.3.2-zen1-2: Battery 0: Discharging, 80%, 02:31:35 remaining

All measures have been taken when the laptop had settled down after booting and under the same load conditions.

Hardware info.:
00:00.0 Host bridge: Intel Corporation Broadwell-U Host Bridge -OPI (rev 09)
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)
00:03.0 Audio device: Intel Corporation Broadwell-U Audio Controller (rev 09)
00:04.0 Signal processing controller: Intel Corporation Broadwell-U Processor Thermal Subsystem (rev 09)
00:14.0 USB controller: Intel Corporation Wildcat Point-LP USB xHCI Controller (rev 03)
00:16.0 Communication controller: Intel Corporation Wildcat Point-LP MEI Controller #1 (rev 03)
00:1b.0 Audio device: Intel Corporation Wildcat Point-LP High Definition Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #1 (rev e3)
00:1c.2 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #3 (rev e3)
00:1c.3 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #4 (rev e3)
00:1c.4 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #5 (rev e3)
00:1d.0 USB controller: Intel Corporation Wildcat Point-LP USB EHCI Controller (rev 03)
00:1f.0 ISA bridge: Intel Corporation Wildcat Point-LP LPC Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation Wildcat Point-LP SATA Controller [AHCI Mode] (rev 03)
00:1f.3 SMBus: Intel Corporation Wildcat Point-LP SMBus Controller (rev 03)
00:1f.6 Signal processing controller: Intel Corporation Wildcat Point-LP Thermal Management Controller (rev 03)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 10)
03:00.0 Network controller: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter (rev 01)
04:00.0 3D controller: NVIDIA Corporation GK208BM [GeForce 920M] (rev a1)

This task depends upon

Closed by  freswa (frederik)
Friday, 21 February 2020, 21:58 GMT
Reason for closing:  None
Additional comments about closing:  This seems pretty stalled to me. If it's still an issue, please fill a re-open request. Thank you :)
Comment by loqs (loqs) - Friday, 04 October 2019, 14:13 GMT
Is there some patch you want applied to the kernel or config option you want changed to resolve the issue [1]?
You can locate the cause by bisecting the kernel [2]. Then you can report the issue upstream [3].

[1] https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines
[2] https://wiki.archlinux.org/index.php/Bisecting_bugs_with_Git
[3] https://www.kernel.org/doc/html/latest/admin-guide/reporting-bugs.html
Comment by Antonio Corbi bellot (acorbi) - Friday, 04 October 2019, 18:09 GMT

> Is there some patch you want applied to the kernel or config option you want changed to resolve the issue [1]?

No. For me this is a regression so, as I have done always, I create a bug report in my OS bug reporting system.

> You can locate the cause by bisecting the kernel [2]. Then you can report the issue upstream [3].

Ok, thanks. I'll try to do it.
Comment by loqs (loqs) - Saturday, 05 October 2019, 18:22 GMT
If you need help bisecting between 5.2 and 5.3 I can provide step by step instructions.

Are there any changes that could be made to [1] that would have caused you not to report
the bug here until you had identified the cause and reported it upstream?

[1] https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines
Comment by Antonio Corbi bellot (acorbi) - Sunday, 06 October 2019, 08:30 GMT
Hi loqs:

> If you need help bisecting between 5.2 and 5.3 I can provide step by step instructions.

I don't know if the problem was yet present into 5.2.x, I noticed it in 5.3.x

> Are there any changes that could be made to [1] that would have caused you not to report the bug here until you had identified the cause and reported it upstream?

No, I'll try to report it upstream.

Thanks for your interest and time.

Loading...