Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64000 - [mesa][linux] Xorg freezes with mesa 19.2.0-2

Attached to Project: Arch Linux
Opened by Stanislav T (stas-t) - Thursday, 03 October 2019, 10:19 GMT
Last edited by Laurent Carlier (lordheavy) - Thursday, 03 October 2019, 15:20 GMT
Task Type Bug Report
Category Packages: Extra
Status Assigned
Assigned To Tobias Powalowski (tpowa)
Andreas Radke (AndyRTR)
Jan Alexander Steffens (heftig)
Laurent Carlier (lordheavy)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Description:

After upgrading mesa to 19.2.0.0 Xorg started freezing when starting certain applications.
Log snippet is attached

Additional info:
* package version(s)
mesa 19.2.0-2
libglvnd 1.2.0-1
lib32-mesa 19.2.0-2
lib32-libglvnd 1.2.0-1
lib32-libpcap 1.9.1-1
lib32-libva-mesa-driver 19.2.0-2
lib32-mesa-vdpau 19.2.0-2
lib32-vulkan-radeon 19.2.0-2
libva-mesa-driver 19.2.0-2
mesa-vdpau 19.2.0-2
python-jinja 2.10.1-2
screen 4.7.0-1
vulkan-mesa-layer 19.2.0-2
vulkan-radeon 19.2.0-2
linux 5.3.1.arch1-1
* logs: see attachment
* hardware: see attached lshw.txt

Steps to reproduce:

Start Xorg with modesetting driver, start Signal Desktop (https://flathub.org/apps/details/org.signal.Signal) - Xorg will freeze almost completely.

The only workaround is to downgrade mesa & related packages to the previous version:

sudo pacman -U /var/cache/pacman/pkg/mesa-19.1.7-1-x86_64.pkg.tar.xz /var/cache/pacman/pkg/libglvnd-1.1.1-1-x86_64.pkg.tar.xz /var/cache/pacman/pkg/lib32-mesa-19.1.7-1-x86_64.pkg.tar.xz /var/cache/pacman/pkg/lib32-libglvnd-1.1.1-1-x86_64.pkg.tar.xz /var/cache/pacman/pkg/lib32-libva-mesa-driver-19.1.7-1-x86_64.pkg.tar.xz /var/cache/pacman/pkg/lib32-mesa-vdpau-19.1.7-1-x86_64.pkg.tar.xz /var/cache/pacman/pkg/lib32-vulkan-radeon-19.1.7-1-x86_64.pkg.tar.xz /var/cache/pacman/pkg/libva-mesa-driver-19.1.7-1-x86_64.pkg.tar.xz /var/cache/pacman/pkg/mesa-vdpau-19.1.7-1-x86_64.pkg.tar.xz /var/cache/pacman/pkg/vulkan-mesa-layer-19.1.7-1-x86_64.pkg.tar.xz /var/cache/pacman/pkg/vulkan-radeon-19.1.7-1-x86_64.pkg.tar.xz
This task depends upon

Comment by Stanislav T (stas-t) - Thursday, 03 October 2019, 10:30 GMT
B.t.w., this behavior is quite similar to the one described in FS#61733.
Comment by kursu (kursu) - Thursday, 03 October 2019, 11:55 GMT
Can confirm this, whole computer freezes. However, think it has to do with my RX 5700 XT, and that I need LLVM-9 for proper support.
Comment by Laurent Carlier (lordheavy) - Thursday, 03 October 2019, 14:44 GMT
Does it works with LTS kernel ?
Comment by Stanislav T (stas-t) - Thursday, 03 October 2019, 15:16 GMT
With LTS kernel (4.19.76-1-lts) it doesn't freeze indeed, thank you for the suggestion!
Comment by Tobias Frisch (TheJackiMonster) - Friday, 04 October 2019, 00:47 GMT
My computer freezes instantly after startup. I guess it's the graphical stuff of GNOME causing it after upgrading mesa to 19.2.0-2. I use a RX 5700 too but the system did not freeze with mesa 19.1.7-1 and even GNOME displayed. I assume the linux-kernel 5.3.1 and the navi-firmware was already enough for general rendering with the RX 5700, so I guess LLVM-9 won't just fix this problem.
Comment by kursu (kursu) - Friday, 04 October 2019, 01:24 GMT
I start X manually with fluxbox. X crashes and computer freezes even before it has even configured a screen. Cant even get a Xorg.0.log printout :) Works with 5.3.2 (custom) and mesa-19.1.7.
Comment by Andreas Radke (AndyRTR) - Friday, 04 October 2019, 05:20 GMT
Please report this to the Mesa devs even if some kernel drm bug may here be the cause.
Comment by Stanislav T (stas-t) - Sunday, 06 October 2019, 09:33 GMT
Upgrading linux from 5.3.1.arch1-1 to 5.3.4.arch1-1 didn't solve the issue.
@kursu: What were the customizations for 5.3.2 kernel that fixed the problem for you?
@AndyRTR: You're right, it should be reported to mesa devs.

UPD: There is still no issue for LTS kernel after upgrading it from 4.19.76-1 to 4.19.77-1.
Comment by Stanislav T (stas-t) - Sunday, 06 October 2019, 10:00 GMT Comment by kursu (kursu) - Sunday, 06 October 2019, 19:24 GMT
@stas-t no my problem is not fixed. I had to downgrade mesa. However I also had problem with the arch kernel not booting (https://bugs.archlinux.org/task/63860).
But a custom compiled kernel with the just needed options solved that problem
Comment by loqs (loqs) - Sunday, 06 October 2019, 22:58 GMT
@kursu if you enable [1] is the issue still present?
If not if you rebuild mesa locally mesa 19.2 with the toolchain from mesa-git is the issue then present?

[1] https://wiki.archlinux.org/index.php/Unofficial_user_repositories#mesa-git
Comment by Kyle (keltek) - Tuesday, 08 October 2019, 23:41 GMT
I can confirm that upgrading to 19.2.0-3 resolved the issue for me.
Comment by Tobias Frisch (TheJackiMonster) - Wednesday, 09 October 2019, 07:23 GMT
Upgrading to 19.2.0-3 worked.. I will test now if some freezes on demanding tasks still appear.
Comment by Stanislav T (stas-t) - Wednesday, 09 October 2019, 14:10 GMT
For me upgrading mesa/llvm-libs/compiler-rt/clang from testing didn't help - see: https://gitlab.freedesktop.org/mesa/mesa/issues/1899#note_254388

UPD: current versions:
clang 9.0.0-2
compiler-rt 9.0.0-2
libva-mesa-driver 19.2.0-3
llvm-libs 9.0.0-2
mesa 19.2.0-3
mesa-vdpau 19.2.0-3
vulkan-mesa-layer 19.2.0-3
vulkan-radeon 19.2.0-3
gnome-builder 3.34.1-2
postgresql-libs 11.5-4
qt5-tools 5.13.1-2
Comment by loqs (loqs) - Wednesday, 09 October 2019, 16:16 GMT
@stas-t as you are encountering VM_L2_PROTECTION_FAULT_STATUS faults providing upstream with output from UMR [1] might help [2]
Have you also looked at bugs featuring VM_L2_PROTECTION_FAULT_STATUS [3]?

[1] https://gitlab.freedesktop.org/tomstdenis/umr
[2] https://bugs.freedesktop.org/show_bug.cgi?id=105251#c23
[3] https://bugs.freedesktop.org/
Comment by kursu (kursu) - Friday, 11 October 2019, 10:46 GMT
Mesa 19.2.1 fixed my problem
Comment by Stanislav T (stas-t) - Saturday, 12 October 2019, 13:29 GMT
For my case adding "--disable-gpu" to signal-desktop command line was the work-around.
Also when I ran signal with a discrete card (env DRI_PRIME=1 ...) - it didn't freeze, however it doesn't survive laptop suspend.
Comment by Stanislav T (stas-t) - Saturday, 12 October 2019, 14:20 GMT
Today I've found this interesting comment:
https://discussion.fedoraproject.org/t/some-flatpaks-kill-the-machine-on-f31sb-beta-testing/7673/4

That would explain why Slack is working fine but Signal freezes (both are based on Electron). See attached output of flatpak info for both.
Comment by Stanislav T (stas-t) - Saturday, 12 October 2019, 16:54 GMT
Not sure if it's a good practice, but I've opened another ticket:
https://github.com/flathub/org.signal.Signal/issues/99
Comment by Stanislav T (stas-t) - Saturday, 12 October 2019, 18:50 GMT
I think the ticket can be closed. The issue is not related to Arch, it's more about flatpak packaging.

Loading...