Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63995 - [gnome-keyring]Gnome-keyring 3.34.0 breaks mate logout. Downgrade needed :(

Attached to Project: Community Packages
Opened by Frederic Bezies (fredbezies) - Wednesday, 02 October 2019, 20:22 GMT
Last edited by Balló György (City-busz) - Friday, 11 October 2019, 20:01 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Brad Fanella (cesura)
Balló György (City-busz)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description: When I upgraded gnome-keyring to version 3.34.0, I noticed that Mate logout is stopped.

A dialog box appears, saying that at-spi-bus-launcher doesn't answer. I had to go a tty, and reboot by hand using sudo reboot.

Downgrading to gnome-keyring-3.31.91 makes logout work again flawlessly :(

Additional info:
gnome-keyring 1:3.34.0
mate-session-manager 1.22.1

Steps to reproduce:

See details.
This task depends upon

Closed by  Balló György (City-busz)
Friday, 11 October 2019, 20:01 GMT
Reason for closing:  Fixed
Additional comments about closing:  mate-session-manager 1.22.2-2
Comment by Frederic Bezies (fredbezies) - Wednesday, 02 October 2019, 20:33 GMT
Looked at mate-desktop github and found this thread: https://github.com/mate-desktop/mate-session-manager/pull/200

I tried building mate-session-manager against gnome-keyring 3.34.0, but it did not work. Again the same bug with at-spi-bus-launcher not "killed" on logout / shutdown process.

Bug reported here: https://github.com/mate-desktop/mate-session-manager/issues/222

Looks like it is related to seahorse 3.34.0 ssh handling. Annoying :(
Comment by Frederic Bezies (fredbezies) - Wednesday, 02 October 2019, 21:31 GMT
Screenshot of the bug, reproduced in a VBox VM. Sorry for the french speaking dialog, but you can see the bug in action.
Comment by Frederic Bezies (fredbezies) - Thursday, 03 October 2019, 08:01 GMT
Here is a journalctl -b0 | grep gnome-keyring output:

oct. 03 08:46:40 fredo-arch-mate kernel: Initialise system trusted keyrings
oct. 03 08:47:47 fredo-arch-mate gnome-keyring-daemon[917]: The Secret Service was already initialized
oct. 03 08:47:48 fredo-arch-mate gnome-keyring-daemon[917]: The SSH agent was already initialized
oct. 03 08:47:48 fredo-arch-mate gnome-keyring-daemon[917]: The PKCS#11 component was already initialized
oct. 03 09:53:42 fredo-arch-mate gnome-keyring-daemon[25455]: couldn't set environment variable in session: Le délai d’attente est dépassé
oct. 03 09:53:43 fredo-arch-mate gnome-keyring-daemon[25455]: The Secret Service was already initialized
oct. 03 09:53:44 fredo-arch-mate gnome-keyring-daemon[25455]: The PKCS#11 component was already initialized
oct. 03 09:53:44 fredo-arch-mate gnome-keyring-daemon[25455]: The SSH agent was already initialized


Le délai d’attente est dépassé -> The waiting period has expired. A timeout?
Comment by Frederic Bezies (fredbezies) - Thursday, 03 October 2019, 08:18 GMT
Saw this in gnome-keyring 3.34.0 release notes:

Changes in version 3.34.0 are:
* dbus-environment: Race fix in Setenv request to gnome-session [!19]
* egg: Request that secure memory not be dumped to disk [!15]
* Build and test fixes [!16, !20, !24, ...]
* Updated translations

Maybe this commit is responsible for the timeout I have with gnome-keyring 3.34.0?

https://gitlab.gnome.org/GNOME/gnome-keyring/commit/5d088356a9473c06564bd2cef18ca370437a17bc

Bug reported on gnome-keyring bugtracker: https://gitlab.gnome.org/GNOME/gnome-keyring/issues/40
Comment by Eivind (mokkurkalve) - Thursday, 03 October 2019, 12:56 GMT
I had the same issue with at-spi-bus-launcher. (I "solved" that with disabling at-spi2, as I don't need it.)
Another issue that occurred was a new hang of about one minute at login, in the transaction between lightdm and the MATE desktop. (Not fatal, but very annoying...)
However, downgrading gnome-keyring 1:3.34.0-1 => 1:3.31.91-1 solved all of that. So there's a bug with gnome-keyring 1:3.34.0-1 used with lightdm and MATE for sure...

Edit: BTW: I do not have seahorse installed.
Comment by Frederic Bezies (fredbezies) - Friday, 04 October 2019, 08:31 GMT
Philip Muller (Manjaro) backported revert patch.

I tested it on my Manjaro Mate powered laptop and it worked.
See here: https://gitlab.manjaro.org/packages/extra/gnome-keyring/commit/eca2f08f66df14241884589f31761068ded98ac7


Will test backport on my main computer now. Keeping fingers crossed. A workaround which won't break Gnome I hope. At least, something to test until a real fix is provided on Mate side.

Edit: patch works. No more delay on mate start or logout problems.
Comment by Frederic Bezies (fredbezies) - Saturday, 05 October 2019, 03:22 GMT
Just before you close it: I can confirm new mate-session-manager, this one - https://git.archlinux.org/svntogit/community.git/commit/trunk?h=packages/mate-session-manager&id=4f82f6addb79099948cb8167c9aaf70e9c0aa2f8 - fixes the issue.
Comment by Frederic Bezies (fredbezies) - Sunday, 06 October 2019, 15:31 GMT
  • Field changed: Percent Complete (100% → 0%)

Loading...