Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63945 - [mesa] causes FATAL:memory_linux.cc Out of Memory crash when starting Chromium.

Attached to Project: Arch Linux
Opened by Matthew Sexton (wsdmatty) - Sunday, 29 September 2019, 04:06 GMT
Last edited by Andreas Radke (AndyRTR) - Thursday, 16 April 2020, 06:47 GMT
Task Type Bug Report
Category Packages: Testing
Status Assigned   Reopened
Assigned To Laurent Carlier (lordheavy)
Felix Yan (felixonmars)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 2
Private No

Details

Description:
After upgrading to testing version 19.2.0-1 of Mesa, Chromium crashes before opening the browser window.

[1537:1537:0928/232202.066810:FATAL:memory_linux.cc(42)] Out of memory.
[1722:1722:0928/232202.661766:FATAL:memory_linux.cc(42)] Out of memory.
[1746:1746:0928/232203.111063:FATAL:memory_linux.cc(42)] Out of memory.
[1755:1755:0928/232203.539134:ERROR:gpu_channel_manager.cc(397)] ContextResult::kFatalFailure: Failed to create shared context for virtualization.


I have a core dump of the process, but it's basically useless. I'm currently in the process of building chromium and mesa with debug symbols to get a usable backtrace.

Once that's done I'll add the backtrace and possibly file a bug report upstream. Here is the current backtrace which shows nothing.




Additional info:
* package version(s)
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:
This task depends upon

Comment by Matthew Sexton (wsdmatty) - Sunday, 29 September 2019, 04:08 GMT
I forgot to mention. I downgraded to the latest stable version of Mesa to verify it was the cause. Downgrading Mesa resolved the problem. Upgrading back to 19.2.0-1 caused the problem to return.
Comment by Matthew Sexton (wsdmatty) - Monday, 30 September 2019, 02:43 GMT
Link to Upstream bug report:
https://gitlab.freedesktop.org/mesa/mesa/issues/1860

Also: i don't think this version of Mesa should've been pushed to testing. According to https://www.mesa3d.org/relnotes/19.2.0.html 19.2.0 is a development release, not a stable release. The next stable release will be 19.2.1.
Comment by Matthew Sexton (wsdmatty) - Wednesday, 02 October 2019, 15:29 GMT
This bug looks to have been addressed upstream. Should be in the next release.
Comment by Laurent Carlier (lordheavy) - Wednesday, 02 October 2019, 16:34 GMT
Please test mesa-19.2.0-2
Comment by Matthew Sexton (wsdmatty) - Wednesday, 02 October 2019, 22:26 GMT
The issue looks to be resolved. My apologies for the delay.
Comment by Martin Sandsmark (sandsmark) - Tuesday, 10 March 2020, 17:47 GMT
  • Field changed: Percent Complete (100% → 0%)
This has started happening again. Luckily out of process, but GPU rendering is disabled.

kernel: traps: chromium[6084] trap invalid opcode ip:55c6c4a32acf sp:7ffdf5864d20 error:0 in chromium[55c6c1784000+6f5b000]

Loading...