Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63929 - [linux-zen] linux-zen-5.3.1.zen1-1 cannot connect to wireguard

Attached to Project: Arch Linux
Opened by Marty (hugtheretard) - Friday, 27 September 2019, 07:14 GMT
Last edited by Antonio Rojas (arojas) - Sunday, 06 October 2019, 15:32 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: Cannot connect to wireguard servers

Additional info:

Re-producible using linux-zen-5.3.1.zen1-1, confirmed this bug does not exist in base linux-5.3.1-arch1-1 package.

journalctl log (wireguard profile name and uuid obscured)

[#] ip link add wireguardprofile type wireguard
Error: Unknown device type.
Unable to access interface: Protocol not supported
[#] ip link delete dev wireguardprofile
Cannot find device "wireguardprofile"
nm-wireguard-se[3513]: g_variant_new_string: assertion 'g_utf8_validate (string, -1, NULL)' failed
nm-wireguard-se[3513]: g_variant_builder_add_value: assertion '!GVSB(builder)->expected_type || g_variant_is_of_type (value, GVSB(builder)->expected_type)' failed
NetworkManager[1210]: <info> [1569565404.9344] vpn-connection[0x55a6560f44c0,99919b45-666e-2222-55c5-89bbae666c39,"wireguardprofile",0]: VPN plugin: state changed: starting (3)
NetworkManager[1210]: <info> [1569565404.9345] vpn-connection[0x55a6560f44c0,99919b45-666e-2222-55c5-89bbae666c39,"wireguardprofile",0]: VPN connection: (ConnectInteractive) reply received
NetworkManager[1210]: <info> [1569565404.9345] vpn-connection[0x55a6560f44c0,99919b45-666e-2222-55c5-89bbae666c39,"wireguardprofile",0]: VPN connection: (IP Config Get) reply received.
NetworkManager[1210]: <error> [1569565404.9347] vpn-connection[0x55a6560f44c0,99919b45-666e-2222-55c5-89bbae666c39,"wireguardprofile",0:(wireguardprofile)]: failed to look up VPN interface index for ">
NetworkManager[1210]: <warn> [1569565404.9348] vpn-connection[0x55a6560f44c0,99919b45-666e-2222-55c5-89bbae666c39,"wireguardprofile",0]: VPN connection: did not receive valid IP config inform>
NetworkManager[1210]: <info> [1569565404.9363] vpn-connection[0x55a6560f44c0,99919b45-666e-2222-55c5-89bbae666c39,"wireguardprofile",0]: VPN connection: (IP4 Config Get) ignoring, the connect>
NetworkManager[1210]: <info> [1569565404.9364] vpn-connection[0x55a6560f44c0,99919b45-666e-2222-55c5-89bbae666c39,"wireguardprofile",0]: VPN plugin: state changed: started (4)
NetworkManager[1210]: <info> [1569565404.9385] vpn-connection[0x55a6560f44c0,99919b45-666e-2222-55c5-89bbae666c39,"wireguardprofile",0]: VPN plugin: state changed: stopping (5)
NetworkManager[1210]: <info> [1569565404.9454] vpn-connection[0x55a6560f44c0,99919b45-666e-2222-55c5-89bbae666c39,"wireguardprofile",0]: VPN plugin: state changed: stopped (6)

More than happy to provide any other details, I was unable to find any useful wireguard logs.

Steps to reproduce:
* Boot kernel
* Attempt to start existing wireguard connection
This task depends upon

Closed by  Antonio Rojas (arojas)
Sunday, 06 October 2019, 15:32 GMT
Reason for closing:  Not a bug
Comment by Marty (hugtheretard) - Sunday, 06 October 2019, 13:03 GMT
I am an idiot and did not build the wireguard-arch-dkms module

Loading...