Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63914 - [pango] Arch Linux's pango binaries break gedit spacing, but upstream pango is fine

Attached to Project: Arch Linux
Opened by Sultan Alsawaf (kerneltoast) - Tuesday, 24 September 2019, 23:55 GMT
Last edited by freswa (frederik) - Monday, 13 April 2020, 21:17 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

For some reason, Arch Linux's pango binaries break fixed-width spacing in gedit, but source-built pango using the same tag as Arch doesn't have the issue. More details (and images of the issue) can be found here: https://gitlab.gnome.org/GNOME/pango/issues/425
This task depends upon

Closed by  freswa (frederik)
Monday, 13 April 2020, 21:17 GMT
Reason for closing:  Fixed
Comment by Eli Schwartz (eschwartz) - Tuesday, 08 October 2019, 02:43 GMT
I replicate this with either the repo package or a git checkout with 'meson builddir/ --prefix=/usr && ninja -C builddir/ install', FWIW
Comment by mattia (nTia89) - Sunday, 12 April 2020, 15:57 GMT
I cannot reproduce the issue.
Is it still valid for you?
Comment by Sultan Alsawaf (kerneltoast) - Monday, 13 April 2020, 14:51 GMT
Jan Alexander Steffens fixed the issue and put a patch for it into pango: https://git.archlinux.org/svntogit/packages.git/tree/trunk/0001-Use-shape-flags-for-tab-width.patch?h=packages/pango

So it is no longer a problem :)

Loading...