Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63898 - [unbound] sysusers.d home set to /etc/unbound creates untracked files

Attached to Project: Community Packages
Opened by David Runge (dvzrv) - Monday, 23 September 2019, 20:56 GMT
Last edited by Gaetan Bisson (vesath) - Tuesday, 24 September 2019, 02:11 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Gaetan Bisson (vesath)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: The sysusers.d integration for unbound [1] sets the home directory of the unbound user to /etc/unbound, whereas it should be set to / (i.e. '-' in the configuration dropin).
After installing (upgrading to) unbound 1.9.3-3 on two of my systems this seems to have lead to a `dev` and a `run` directory being created below /etc/unbound.

The upstream recommendation in regards to setting home directories [2] seems to be to leave it unset, unless the application requires a home directory. Is this the case for unbound?
I have tested setting the home directory of the unbound user to / instead and it doesn't seem to have any observable side effects.

If this is not required, please set the home directory to '-' instead of '/etc/unbound'.

Thanks!

[1] https://git.archlinux.org/svntogit/community.git/tree/trunk/sysusers.d?h=packages/unbound
[2] https://www.freedesktop.org/software/systemd/man/sysusers.d.html#Home%20Directory

Additional info:
* package version: 1.9.3-3

Steps to reproduce:

* install unbound
This task depends upon

Closed by  Gaetan Bisson (vesath)
Tuesday, 24 September 2019, 02:11 GMT
Reason for closing:  Upstream
Comment by Gaetan Bisson (vesath) - Tuesday, 24 September 2019, 02:10 GMT
I prefer to have a sensible home directory for unbound, but this is not what causes those `dev` and `run` directories to be created. They come from the new upstream service file and more specifically the lines:

TemporaryFileSystem=/etc/unbound/dev:ro
TemporaryFileSystem=/etc/unbound/run:ro

If those directories are a problem for you please get in touch with upstream and report it to them. Cheers.

Loading...