Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63875 - gdm auto switch user.

Attached to Project: Arch Linux
Opened by Alexander (Taetricus) - Saturday, 21 September 2019, 10:23 GMT
Last edited by Antonio Rojas (arojas) - Tuesday, 08 October 2019, 16:49 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
automatic switching from one user's session to the lock screen in another user's session. Reverse switch by clicking on ctrl + alt +f<Number>, but returning to first session and press control + c - session ends.

Additional info:
package version - gdm 3.34.0-2
first session - gnome wayland
second session - gnome wayland
In the attached file, a cut of the logs at the time when the bug occurred and in which gdm is mentioned.

Steps to reproduce:
Start the session of the first user, then click "switch user", start the session of another user, after 10-15 seconds the lock screen of the first user appears.
   log (5.6 KiB)
This task depends upon

Closed by  Antonio Rojas (arojas)
Tuesday, 08 October 2019, 16:49 GMT
Reason for closing:  Fixed
Comment by Erik Kallen (erikkallen) - Wednesday, 25 September 2019, 08:51 GMT
Same issue here, I can only log in to one user account, when switching to another user I get returned to the locked screen.
It now shows the unlock screen, so the user does seem to be logged in.
Trying to unlock does not work, I can however go back to the first user that logged in.
Comment by Marc van Gend (marcvangend) - Wednesday, 25 September 2019, 21:01 GMT
Confirming this issue. I just did a fresh install (nothing special, just followed the install guide) and added Gnome-shell, GDM and some basics like a couple of packages from gnome-extra and Chromium. Then I added a second user account (used the Gnome GUI for that), switched to that user, and the issue occurred.

What's interesting: My old laptop has had the same issue since a recent update. I shrugged it off as old age or mis-configuration of the system, knowing that my new laptop would be arriving soon. But now that it's happening on a fresh install too, I think it's a proper bug.

I'm usually running Gnome on Xorg, but the issue seems to occur on Wayland as well.
Comment by Marc van Gend (marcvangend) - Saturday, 28 September 2019, 13:55 GMT
This Fedora issue describes the same behavior: https://bugzilla.redhat.com/show_bug.cgi?id=1751673
It mentions this as upstream fix: https://gitlab.gnome.org/GNOME/gdm/merge_requests/86

I tried to build GDM from source to see if it solves the problem, but stopped when I ran into (probably unrelated) errors. Anyway, it looks like this will be fixed in the next release.
Comment by Marc van Gend (marcvangend) - Tuesday, 08 October 2019, 08:42 GMT
I just did an update which included GDM 3.34.1 release. The release notes mention "Fix fast user switching by assuming the login screen VT is always the initial one" and indeed the problem is gone on my machine.

Loading...