Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63863 - [gnome-shell] (3.34.0+94+g3d86e6e79-1) Switching keyboard layout as Alt+Shift doesn't work.

Attached to Project: Arch Linux
Opened by Artemii Sudakov (Bitedasher) - Friday, 20 September 2019, 15:03 GMT
Last edited by Jan de Groot (JGC) - Friday, 25 October 2019, 07:38 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description:
Switching keyboard layout on shortcuts, which was set in Gnome-Tweaks/setxkbmap doesn't work. I can change keyboard layout only by pressing Super+Space. But any other shortcuts doesn't work at all. I only can hear a notification sound, but not layout changing. This problem only affects at Xorg session, Wayland work good.
This task depends upon

Closed by  Jan de Groot (JGC)
Friday, 25 October 2019, 07:38 GMT
Reason for closing:  Fixed
Additional comments about closing:  3.34.1 includes the mentioned fix
Comment by Korkiat Petsiri (mrlamud) - Saturday, 21 September 2019, 01:13 GMT
I do confirm this bug.

If you wish to correct switching key in xorg, you can manage in dconf Editor ../org/gnome/desktop/wm/keybindings/switch-input-source.
Comment by Artemii Sudakov (Bitedasher) - Saturday, 21 September 2019, 17:23 GMT
It doesn't work even if i try change it in dconf
Comment by Shalygin Konstantin (k0ste) - Monday, 23 September 2019, 02:42 GMT
I have this bug too.

But switching start working after segfault of gnome-shell...

```
[Mon Sep 23 09:25:16 2019] gnome-shell[968]: segfault at 0 ip 00007f44c98efaa0 sp 00007ffd70b3c178 error 4 in libcairo.so.2.11703.0[7f44c98c9000+cf000]
[Mon Sep 23 09:25:16 2019] Code: 74 10 8b 00 85 c0 75 0a 8b 87 70 01 00 00 c3 0f 1f 00 48 83 ec 08 bf 0d 00 00 00 e8 4a fe fe ff 31 c0 48 83 c4 08 c3 0f 1f 00 <48> 8b 07 48 85 c0 74 10 8b 00 85 c0 75 0a 8b 87 74 01 00 00 c3 0f
[Mon Sep 23 09:25:17 2019] [drm] Reducing the compressed framebuffer size. This may lead to less power savings than a non-reduced-size. Try to increase stolen memory size if available in BIOS.
```
Comment by Peter (Rinaldus) - Monday, 23 September 2019, 07:59 GMT
I found temporary solution. If you press Alt+F2 and input "r" there (to restart gnome-shell), keyboard switching starts to work again. But only in current session. You have to repeat it every time after booting. I hope, that the developers will fix it soon.
Comment by Ariel Shatil (denomolo) - Tuesday, 24 September 2019, 06:47 GMT
Confirmed from me as well. Reloading the shell fixes it for current session.
Comment by Shalygin Konstantin (k0ste) - Tuesday, 24 September 2019, 06:54 GMT
Works for me too, thanks for workaround.
Comment by Amiad (amiad) - Thursday, 03 October 2019, 09:44 GMT
I have this problem too. It is very difficult to work with two layouts.
Comment by Peter (Rinaldus) - Monday, 07 October 2019, 15:40 GMT
Here's patch for Mutter, that fixes this problem. And also modified PKGBUILD with patch included. I rebuilt Mutter with this patch and keyboard layout switching works again.
Comment by Peter (Rinaldus) - Monday, 07 October 2019, 22:35 GMT
This bug is fixed by upstream in #ce86f90efbaa51522ba14c5b4cad933c2106de42 (https://gitlab.gnome.org/GNOME/mutter/commit/ce86f90efbaa51522ba14c5b4cad933c2106de42). If you rebuilt Mutter with latest commit, it will be fixed.

Loading...