Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63861 - [bluegriffon] doesn't build

Attached to Project: Community Packages
Opened by Andreas Baumann (andreas_baumann) - Friday, 20 September 2019, 12:28 GMT
Last edited by Balló György (City-busz) - Friday, 04 October 2019, 14:05 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Muflone (muflone)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Fails building the embedded Mozilla.

Additional info:
* package version(s): 3.1-6

Steps to reproduce:
asp export bluegriffon
cd bluegriffon
staging-x86_64-build
   log.txt.xz (450.1 KiB)
This task depends upon

Closed by  Balló György (City-busz)
Friday, 04 October 2019, 14:05 GMT
Reason for closing:  Fixed
Additional comments about closing:  bluegriffon 3.1-7
Comment by loqs (loqs) - Friday, 20 September 2019, 20:20 GMT
Possibly fixed by https://github.com/mozilla/gecko-dev/commit/be4391585f7069c6bcb9efb364a97bd3554d6a01
Edit:
Does not apply cleanly and can not be cherry-picked easily due to large amounts of code change between the two commits.
rust-explicit-dyn.patch adds the missing dyn. Alternatively the warning as error could be removed making it none fatal.
Build tested only.
Comment by Balló György (City-busz) - Friday, 04 October 2019, 14:03 GMT
@loqs: thanks for the patch!

Loading...