Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63856 - [cairo] Glyph rendering issues when used by poppler for viewing PDF

Attached to Project: Arch Linux
Opened by Léo Grange (Kristaba) - Friday, 20 September 2019, 10:06 GMT
Last edited by freswa (frederik) - Sunday, 13 September 2020, 15:59 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description:

Since last Cairo update, many PDF viewers (probably all the ones using poppler) have apparently random glyph rendering issues: text missing, huge characters appearing across the document, bad font and positioning...
Theses glitches may appear and disappear depending the zoom level or the canvas size.
They are important enough to make reading complex document difficult or to cause huge trouble when presenting PDF slides.

Several issues where opened (in evince, then poppler and finally cairo) and the root cause seems to be some cairo recent commit (c.f. upstream bug report).
It seems that only Arch is packaging such a recent version of cairo, so it may explain why it has not been noticed earlier.

I don't know the Cairo project well enough, but it does not seems very active currently.
As this bug can be a real trouble for many Arch users (slides content changing in the middle of public presentations for instance), it may be great to find a temporary fix before it gets solved upstream.
More technical information is available in the cairo issue.


Additional info:

Issue occurs with cairo 1.17.2+17+g52a7c79fd-1, and seems fixed by downgrading package to cairo 1.16.0-2 .

Upstream bug reports:
* Cairo issue: https://gitlab.freedesktop.org/cairo/cairo/issues/376
* Poppler issue (for reference): https://gitlab.freedesktop.org/poppler/poppler/issues/826
* Evince issue (for reference): https://gitlab.gnome.org/GNOME/evince/issues/1244


Steps to reproduce:

Many examples of buggy PDF files are provided in the evince issue, but as it depends on many parameters (zoom level, canvas size, etc...) it is difficult to give exact steps.
Just open a sufficiently complex document (ideally some LaTeX/Beamer with some maths) and scroll/zoom until huge characters appears randomly.
This task depends upon

Closed by  freswa (frederik)
Sunday, 13 September 2020, 15:59 GMT
Reason for closing:  No response
Comment by Bruno Pagani (ArchangeGabriel) - Sunday, 22 September 2019, 17:17 GMT
Thanks for tracking this issue. I was indeed deeply affected while having the issue live during PhD defence… rehearsal, thankfully. But my advisor first question while pretending to be my jury was “What do you take? Where do you supply from?”. Since my actual defence is on Wednesday, I’ll go the downgrade Cairo route for now.
Comment by Jan Alexander Steffens (heftig) - Saturday, 05 October 2019, 12:31 GMT
Please try 1.17.2+17+g52a7c79fd-2 from testing, which includes https://gitlab.freedesktop.org/cairo/cairo/merge_requests/28

Loading...