Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63848 - [intel-media-driver] needs rebuild against updated intel-gmmlib (libigdgmm.so.9 -> libigdgmm.so.11)

Attached to Project: Community Packages
Opened by mike (mbalajew) - Friday, 20 September 2019, 01:14 GMT
Last edited by Daniel Bermond (Bermond) - Friday, 20 September 2019, 18:08 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Bruno Pagani (ArchangeGabriel)
Daniel Bermond (Bermond)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Updating intel-gmmlib from 19.3.2-1 to 19.2.4-1 appears to break VA-API hardware video acceleration. Running `vainfo` produces the following error:

$ vainfo
libva error: dlopen of /usr/lib/dri/iHD_drv_video.so failed: libigdgmm.so.9: cannot open shared object file: No such file or directory
vaInitialize failed with error code -1 (unknown libva error),exit

Downgrading the package fixes the error.

Steps to reproduce:

1) Update intel-gmmlib from 19.3.2-1 to 19.2.4-1
2) Run `vainfo`
This task depends upon

Closed by  Daniel Bermond (Bermond)
Friday, 20 September 2019, 18:08 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in 19.2.1-2.
Comment by mike (mbalajew) - Friday, 20 September 2019, 01:23 GMT
Maybe I should add that I'm using the iHD libva driver provided by the package `intel-media-driver`
Comment by Michel Koss (MichelKoss1) - Friday, 20 September 2019, 12:09 GMT
I guess intel-media-driver need a rebuild against current intel-gmmlib
Comment by mike (mbalajew) - Friday, 20 September 2019, 13:00 GMT
I'm not sure how helpful this will be, but, I just rebuilt `intel-media-driver` on my machine and indeed this does seem to fix the issue.
Comment by Eli Schwartz (eschwartz) - Friday, 20 September 2019, 16:30 GMT
  • Field changed: Summary (latest update to intel-gmmlib breaks harware video acceleration → [intel-media-driver] needs rebuild against updated intel-gmmlib (libigdgmm.so.9 -> libigdgmm.so.11))
  • Field changed: Status (Unconfirmed → Assigned)
  • Task assigned to Bruno Pagani (ArchangeGabriel), Daniel Bermond (Bermond)
Using "checkpkg" before upload should show when the soname changes, this error could be avoided. Please consider getting into the habit of using checkpkg. :)
Comment by Daniel Bermond (Bermond) - Friday, 20 September 2019, 16:54 GMT
Thanks for the tip Eli! :)
Fixed.
Comment by Daniel Bermond (Bermond) - Friday, 20 September 2019, 18:05 GMT
Closing as it's fixed now.

Loading...