Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63847 - [linux] iwlwifi crashes with 5.3.0-arch1-1 and Intel 8260

Attached to Project: Arch Linux
Opened by Ilya Lipnitskiy (lipnitsk) - Friday, 20 September 2019, 00:22 GMT
Last edited by Jan de Groot (JGC) - Tuesday, 08 October 2019, 07:33 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 15
Private No

Details

Description:
Module crashes with symptoms described here: https://bugzilla.kernel.org/show_bug.cgi?id=204151

This task depends upon

Closed by  Jan de Groot (JGC)
Tuesday, 08 October 2019, 07:33 GMT
Reason for closing:  Fixed
Comment by Ilya Lipnitskiy (lipnitsk) - Friday, 20 September 2019, 04:28 GMT
Log for FW error in SYNC CMD GEO_TX_POWER_LIMIT attached.
Comment by Merlin Schumacher (merlin.schumacher) - Friday, 20 September 2019, 12:52 GMT
I can confirm the issue with the 8260 and the same error message. Happens since the upgrade to 5.3
Comment by Geoffrey Host (carbonchauvinist) - Friday, 20 September 2019, 15:17 GMT
Can confirm the same issue with 8260 and 5.3.0-arch1-1 (see full details of card below):

01:00.0 Network controller [0280]: Intel Corporation Wireless 8260 [8086:24f3] (rev 3a)
Subsystem: Intel Corporation Wireless 8260 [8086:0050]
Flags: bus master, fast devsel, latency 0, IRQ 133
Memory at dcb00000 (64-bit, non-prefetchable) [size=8K]
Capabilities: [c8] Power Management version 3
Capabilities: [d0] MSI: Enable+ Count=1/1 Maskable- 64bit+
Capabilities: [40] Express Endpoint, MSI 00
Capabilities: [100] Advanced Error Reporting
Capabilities: [140] Device Serial Number f4-8c-50-ff-ff-06-61-39
Capabilities: [14c] Latency Tolerance Reporting
Capabilities: [154] L1 PM Substates
Kernel driver in use: iwlwifi
Kernel modules: iwlwifi

If needed, I can post full journal or portions of journal from affected boots when I'm back in front of my box tonight.

--edit-- added full journal (well removing a lot of noise from baloo) from an affected boot. Also added one that is only the errors from the same boot.
Comment by Matthias Blankertz (drowfx) - Monday, 23 September 2019, 06:23 GMT
Might also be related to this thread on lkml: https://lkml.org/lkml/2019/8/17/7
Unfortunately, reading the 5.3.1 changelog it seems that upstream has not yet fixed the issue.
Comment by Arnaud Baes (arbaes) - Wednesday, 25 September 2019, 09:07 GMT
I just ran into the same issue myself, same card (see relevant attached file)

I attached the log with errors only and the full log aswell.
Comment by Ilya Lipnitskiy (lipnitsk) - Wednesday, 25 September 2019, 17:32 GMT
Should be fixed in this patch: https://patchwork.kernel.org/patch/11158395/
Comment by Julian Phillips (chr0mag) - Saturday, 28 September 2019, 17:37 GMT
I see this too but it only seems to be triggered when using the latest version of IWD (0.21-1). Downgrading to IWD v0.20-3 works around the issue for me while running the latest (v5.3.1) kernel.

My card is the same: Intel Corporation Wireless 8260 [8086:24f3] (rev 3a)
Comment by Geoffrey Host (carbonchauvinist) - Wednesday, 02 October 2019, 00:23 GMT
I've been holding off on upgrading linux due to this issue. I tried again today and looks like this is fixed now? At least for me.

Maybe it was this?
upgraded linux-firmware (20190815.07b925b-1 -> 20190923.417a9c6-1)
Comment by Ilya Lipnitskiy (lipnitsk) - Wednesday, 02 October 2019, 00:41 GMT
Still broken for me, and the 8260 firmware did not update (still at 36.77d01142.0). Also, it doesn't look like the patch from https://patchwork.kernel.org/patch/11158395/ made it into 5.3.2 :( Will probably have to wait until 5.3.3...
Comment by loqs (loqs) - Wednesday, 02 October 2019, 00:54 GMT
The commit was cherry-picked for 5.3.2-arch1 [1]. Please test once the package has moved out of staging.

https://git.archlinux.org/linux.git/commit/?h=v5.3.2-arch1&id=bba6b64830f869b44e3ffb948f370b11ee5e42c5
Comment by Ilya Lipnitskiy (lipnitsk) - Monday, 07 October 2019, 16:54 GMT
Fixed in 5.3.4-arch1-1

Loading...