Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63835 - [shared-mime-info] PLEASE ENTER SUMMARY

Attached to Project: Arch Linux
Opened by Samuel Cazayus (MrCaza) - Thursday, 19 September 2019, 08:05 GMT
Last edited by Andreas Radke (AndyRTR) - Monday, 07 October 2019, 09:03 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

*Description:
In the two last versions 1.13.1-1 and 1.13.1-2 Inkscape crashes when calling some functions (https://bugs.archlinux.org/task/63803). Downgrading shared-mime-info to 1.12-1 solved the problem, but I don't know the exact origin of it since inkscape throws an error which is not obviously related to this package :

###
(inkscape:24752): glibmm-CRITICAL **: 10:58:01.939:
unhandled exception (type Glib::Error) in signal handler:
domain: gdk-pixbuf-error-quark
code : 3
what : Format d’image non reconnu
###

Thank you for reading !
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Monday, 07 October 2019, 09:03 GMT
Reason for closing:  Fixed
Comment by Andreas Radke (AndyRTR) - Thursday, 19 September 2019, 15:18 GMT
https://gitlab.freedesktop.org/xdg/shared-mime-info/issues - bring it there and provide the test file - or git bisect the error.
Comment by Lin Xiao (xiaoliniess) - Sunday, 22 September 2019, 08:56 GMT
Though I also don't know what the problem is, but maybe this is related: https://gitlab.freedesktop.org/xdg/shared-mime-info/issues/116
Comment by Andreas Radke (AndyRTR) - Saturday, 05 October 2019, 12:05 GMT
Has this been solved with 1.14 release?
Comment by Samuel Cazayus (MrCaza) - Monday, 07 October 2019, 07:59 GMT
Yes, the 1.14 solved it !

Loading...